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How to Allow the SCADA/HMI to Access Win-GRAF Variables?

Download FAQ-008 Demo

This FAQ-008 provides a Win-GRAF project called “fag008” which includes two LD programs. One is used
to get/set the PAC system time (i.e., the “PAC_Time” program) and the other is used to create a blinking
function (i.e., the “LD1” program). The user can refer Win-GRAF Getting Started — Chapter 2 (Demo01) to
know more details.

Moreover, this paper describes how to set up Win-GRAF variables as public data by enabling the
Win-GRAF PAC as the Modbus TCP slave or the Modbus RTU slave so that the SCADA/HMI software
(e.g., “InduSoft”) can access Win-GRAF PAC’s data. Follow the instructions below to set up.

Note: The following setting has been completed in the “faq008” project. The user can run the Win-GRAF
and then click File > Add Existing Project > From Zip in the menu bar to restore this project (or
refer the FAQ-003).

1.1. To Enable the Win-GRAF PAC as a Modbus TCP Slave

1. Click the “Open Fieldbus Configuration” tool button to open the “lIO Drivers” window.

[ Win-GRAF - Demo01

File Edit View Insert Project Tools Window Help
=TI e % flafse am i BwA
Workspace 10 Drivers *
=l Demol E Mame | Walue “F Mame | Type
[ Exception prog... 5 2} Global variables »
[ Programs . PAC Year DIMNT
“FE] PAC_Time... B PAC Manth  DINT
€] LD [Blink.. || — PAC Day DIMT
I_J Watch [fclr dE E ™ Aniaal. MilhIT
&% Soft Scope — —
= Iritial valuss Q Name | Walue
%4 Binding Corfig... || &%
3 g Global defines
ﬁj Warnables g+
B Types
< |
4 FAC Time “Wariables LD1
Build
C:%win-GRAFYWProjectshDemallh,
Mo emor detected
4 » | Euild Cross references Runtime Call stack Ereakpoint= Digital sampling trace Frompt Hhbdl
Ready Offline 192,168,255, 1:502 é 0,0 0x0 0,0
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2. Click the “Insert Configuration” button on the left side of the “IO Drivers” window and then select the
“MOSBUS Slave” and click “OK” to enable a Modbus TCP Slave.

10 Drivers *

= M arne | “alue
[

Add Confignration

Chooze a configuration

=

1B

- Al

d 1 MODBUS
H - MODBUS Master

B 1{ODELS Slave

4k FALC Time “wWariables LC1 | 1D Drivers

3. Click the “Insert Master/Port” button on the left side to set the “Slave number” (In this case, the value
is “1”), and click the “OK” button.

10 Drivers *
W EYMODBUS Slave

Marme | Walue

HMODBUE Slave Frotocol

Slave number;

Slave rurnber | Server D

4 ¥ PALC Time ‘Jariables L1 | 10 Drivers

4. Click the “Insert Slave/Data Block” button on the left side to open the “MODBUS Slave Request”
window.

...... o Slave rumber 1

\ Server ID\
= \ Tips:
B
i

e
|8 Mg MODBUS Slave Marme | value
5

1. Press the “F1” key to open the Help on this subject.
2. If you add two or more “Server - ...” settings, type a
“Server ID” for easier use (a string, e.g., 'SVR1’)

Request | Address | Wb Item | Description |

4 PALC Time ‘Jariables LC1 | 10 Drivers
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5. Enter a simple note in the “Description” field and then click the "Input Registers” option.

MODBUS Slave Request X

Fequest

Ciescription: Fead_Value

12N

Drata read by the master

Enter a simple note.

i) Input: Bits

%t Registers
Data read or Farced by Ehe masker

) Coil Bits
) Holding Registers

Drata block,

Base address:
2000

Hb items:

Recommend to set
“Base address” to “1”
and set the value of
“Nb items” is greater
than “200”.

For Modbus Master to Read data:

Options Data types

Input Bits BOOL

Input Registers | o' 167 INT, DINT,
’ ° REAL, etc.

For Modbus Master to Write data:

Options Data types

Coil Bits BOOL

Holding BYTE, INT, DINT,
Registers REAL, etc.

6. As the screenshot above, it is recommended to set the “Base address” to “1” and the “Nb items”

refers to how much variable data can be provided by one “data block”. If the data address requested

from the Modbus Master (e.g., the SCADA software) is greater than this value (in this example, the
value is “2000”), the Modbus Slave (i.e., Win-GRAF PAC) will not respond.

7. Mouse drags all the needed variables (e.g., “PAC_xxx”, data type: “DINT”) one-by-one from the

Variables area and then drop it to the “Symbol” field.

1t Drivers *
E Mg MODEBUS Slave M ame | Walue I Mame | Type | Crimn.
S & Server - Slave number = 1 Request  lnput Registers PAC Month DIMT *‘_\
8 (- *B Input Registers [1..2000] - Read V| Adufess 1 PAC Day DINT
Nbltem 2000 PAC WeekDay DINT 1
= Descriphi.. Fead Value PEC_Hoft DT
. PAC _Minute DINT
= Symbal | Offset | Mask | Storage | F PAC Second DIMT v
S PAC ear 1] FFFF Default Fy ,l| 5
N —7 -
&5 PALC_kanth 1] FFFF Diefauilt Mames | Value |
PALC_Day 1] FFFF Diefault Py
. Haur efault P
B Pac_H 0 FFFF Defaul i
”
PAC_Minute 1] FFFF Drefault _- =
PALC_Second 1] FFFF Diefauit ~
| >
4 r PAC Time ‘JWariables L1 | 1D Drivers
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8. Mouse double-click the “Offset” field and fill in a value, then press “Enter” key to finish the setting.

Note: (1) The “Offset” value starts at “0” and the Modbus address of variable is equal to this value

plus 1 (B

ase address).

(2) If using a 32-bits (or more than 32-bits) data type (e.g., “DINT”), it requires two Modbus
addresses, as the table below, the “Offset” values are “0”, “2”, “4”, “6”, etc.

Tips:

Swrbal | Offset | Mazk | Storage
FALC_ear 1] FFFF Drefault
PALC_kaonth 2 FFFF Drefault
PAC_Day 4 FFFF Drefault
FAC_Hour B FFFF Default
PAC_Minute o8 v || FFFF Default
PAC_Second 0 FFFF Drefault
FALC \WeekDay 0| Enter FFFF Default

Mouse click the “Offset” field and press the keyboard “Ctrl+A” to select all items, and then click the
“Iterate Property” button at the left side to open the settings window.

4

g2

g+

FAC_Minute Ctri+A Crefault
C_Second Drefault

Symbol | Offset £ | Mask | Storage
FaAC _Year Crefault
FPALC_konth Drefault
PAC_Day Drefault
FAC_Hour Drefault

PAC wWeekDay Drefault

Keep the “Name” setting, enter “0” into “From” field and enter “2” into “By” field, then click “OK”.

(If the “Name” is set to “%%”, it will show “00, 22,
44, 66, 88, 1010, 1212” in this example. The user

Name % | can modify it depends on the needed settings and
Fram: By 2 ¥ then check the value in the “Results” area.)
Rezultz
Skl | Offset 4| Mask | Storage
PAC ear 0 FFFF Drefauilt
FAC_Month 2 FFFF Drefault
FAC_Day 4 FFFF Drefault
FaC_Hour G FFFF Drefault
PAC_Minute a FFFF Drefauilt
PAC_Second 10 FFFF Drefauilt
[ ok ! | Ca PAC_WeekDay |12 FFFF Default
AN

L >

F&AC Time ‘Jariables LE1 | 10 Drivers
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9. Click “Storage” to select entire columns and then press “Enter” key to display a drop-down menu.

Then, select “DWORD (Low — High)” and press “Enter” key to complete the setting. (If using a 16-bits

or below, it is no need to set the “Storage” item.)

Symbal | Offzet | bl ask | Storage £ | Fange [Low]

PAC_vear 1] FFFF Drefault \

PAC_Manth 2 FFFF D efault

PaC_Day 4 FFFF Drefault

PAC_Haour G FFFF Drefault

PAC_kinLte a FFFF Drefault

PAC_Secand 10 FFFF [iaF=uie

PAC WeekDay 12 FFFF ] oy AT

C'wWORD [Low - Highl

< STRINGE) >

FAC Time “Wariables LC1 | 10 Drivers STRIMG[T0]

To expand this “Data Block” and you can see the Modbus addresses of all variables. It equals to the

“Offset” value plus “1” (Base address).

10 Drivers *
E =) Input Reqisters [1..2000] - Read_Value Mame | " alue
2 2| +0.1; PAC_Year Request [nput Registers
] =) +2.3: PAC_Manth Address 1
8 | +4..5: PAC Dap ME Item 2000
= | +6..7: PAC_Hour Dezcnption  Read_alue
E =3 +3..9 PAC_Minute
=) +10..17: PAC_Second
g . =] +12..13 PAC WeekDay W
28 Symbol | Diffset | Mask | Storage | Range (Lo
o PAC ear 0 FFFF Dw/ORD [Low - High)
PAC_Month 2 FFFF Dw/ORD [Lows - High)
FaC_[ay 4 FFFF [wORD [Low - High)
PAC_Hour E FFFF Dw/ORD [Low - High)
PAC_Minute 8 FFFF Dw/ORD [Low - High)
PAC_Second 10 FFFF Dw/ORD [Lows - High)
PaC_‘weekDay 12 FFFF [wORD [Low - High)
< >

10. Then, we need to add the second “Data Block” for the Modbus Master to read the Boolean data.
This configure way is similar to the step 4 to 8:
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(1) Click the “Server - ..."” item and click the “Insert Slave/Data Block” button at the left side to open
the settings window.

(2) Inthe “MODBUS Slave Request” window, enter a simple note and select the “Input-bits” option,
then set “Base address” to “1” and set “Nb items” to “2000”.

10 Drivers *
M@ MODBUS Slave

. - Slave number = 1

=z ' :
Fegizters [1..2000] - Read_alue
fl’ \ MODBUS Slave Request |
¥
H

Request

Description: |Read_Bu:u:uIean |

Daka read by the maske)

Enter a simple note

(%) Input Bits
() Input Reqgiskers

For the Modbus Master to Read data:

Data read ar forced by the masker

Option Data Type O coll Bits
Input Bits BOOL (") Holding Redgisters
Inbut Registers BYTE, INT, DWORD, Data black

put Reg REAL, LINT, etc. 350 acess:

M items: 2000

(3) Mouse drags the Boolean variables (i.e., “LED1”, “LED2”; data type: BOOL) one-by-one and drop
them to the “Symbol” area, and then set the “Offset” to “0” and to “1”.

10 Drivers *

12 Eﬂ-; Server - Slave number = 1 # || Mame | Walue I __Mame | Type

3 [nput Beagisters [1..2000] - Read al Request Input Bitz LEDM BOOL |
I npuit Bits [1..2000] - Res Address 1 02 BOOL |
B @ +0: LEDA Mbltern 2000 1 gl RETAIN variables -
ik @ +1: LED2 || Description  Fead_Boolean ;l il 3

w = —

o Surnbial 1fos:et= bask | Storage | Rang ¢hame R

B (epy 0 FFFF Default _-

¢5 LED2q _ _ \ ) FFFF Defaut_ _ - =~

i@ r=-" 3¢ IE:

4 PALC Time ‘JWariables LC1 | 10 Drivers

You have completed the settings for the Modbus Slave. Finally, follow the way below to re-compile
the program and download it to the Win-GRAF PAC.
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11. Click “Project” > “Build All Projects” from the menu bar to compile this program again (as the figure
below). If a message informs you, “No error detected” that means this process is successful.

On Line Change iz dizabled

[MODBUS-5] (4] PAC_vear: W arning: 32 bit word ardering not supported by runtime 7.4 and alder
[< CT Segment = 55 byte(z) » ]

<10z

R elocating code. ..

¢ Code CRC=323797fc - File CRC=eb3d0z16 - Size=3672 »

(>

This version information can be ignored.

W

4 * Build Crozf references Runtime Call stack Ereakpoint= Drigital zampling trace Frompt Hhdl

12. Mouse right-click the project name (i.e., “Demo01”) and select the “Communication Parameters...” to
set the PACIP (e.g., “192.168.71.19:502"”) and then click the menu bar “Project” > “On Line” (or 'l
to establish a connection and download this project to the Win-GRAF PAC.

™ Win-GRAF - Demo01

File Edit View Insert BEmEEs Tool: Window Help
S = M@ Buid Al Projects F?
| Workspace Clean 811 Projects
-4 Demol .
Fil: Edit ¥iew Insert Pmiject Tools Window : %5 Download Al Frojects...
—— | @ 1 Erception pro et
AN B2 AN I TRECEECNS -3 Programs =
Worksnare PAC_Tim | . “] pgg_nn[,m On Line wy Ctl+F5
et | DB | Sl N F5
j Cormmication Farameters. @
| Al OnlLine \
SCADA / HMI Win-GRAF PAC

IP: 192.168.71.19

~ =
L&/ InduSoft | = __j Port: 502
InduSoft ‘ < >
-

Slave number =1

IP: 192.168.71.xxx WP-5xx8-CE7 WP-8xx8
Mask: 255.255.255.0

Modbus TCP Master Modbus TCP Slave

After completing all the steps, the HMI/SCADA software can access to all the Win-GRAF variables listed
above via Modbus TCP protocol.
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1.2. To Enable the Win-GRAF PAC as a Modbus RTU Slave

Before doing this, you must complete all the content that described in Section 1.1 to open the Modbus
Slave data. The way to enable the Win-GRAF PAC as the Modbus RTU Slave is to add the “MBSLAVERTU”
or the “MBSLAVERTUEX” function block in the program. To begin, follow these steps:

1.2.1. Add the “MBSLAVERTU” function block

1. Inthe “LD1” window, mouse click the place where you want to add this function block and then click
the “Insert FB..” button on the left side of the window.

LEC

R1
mll RUR BLIMK |
= I LEDZ
| TH2S |CYCLE |
%K1.1.0
Ot
= |
K1 11
! Output?
3 I
WK1 2
= OutpUts

< >

4 PAC Time \u"ariableD Crrivers

2. Double-click on this function block and select the name “MBSLAVERTU”, then click “OK”.

F2 IR

8 ol I
>y |

N i

[ 8 [1§
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TF LWL (*Matural lagarithm (LREAL))

1F LOADSTRING [*Get a string from a table®)

TF LOBYTE [“Low part of & ward?]

1T LOG [*Logarithm [base 10)%]
LOGFILECSY [*Generate log file in C5Y format®)
T LOGL [*Logarithm [base 10 - LREAL))

IF LOGMESSAGE [*send a LOG message”]

1T LOWORD [*Low part of & double ward®]

TF MAKEDWORD [*Pack waords to double ward?]
TF MAKEWORD [*Pack bytes bo ward®]

I MAX [*M aximum™]

MBMASTERRTU [*MODBUS Master RTU)
MEMASTERTCP [*MODEUS b aster TCP?)
TTF MBSHIFT [*Multibyte shift/robate?]

L} 4R & [LE [ i N elleyice

MBSLAVERTU [*MODEUS Slave RTU [senal]*]

dentification®)

zF MESCAVER TOE=TMUDED ave h L [zenall”

Y

Tips:
Press the “MBSL” key to find
the function name quickly.

b Inputs:

[ o ‘{[ Cancel

3. Inthe “MBSLAVERTU” function block, mouse double-click the left side of the “PORT” and enter a
string 'COM2:9600,N,8,1' (it means using the Win-GRAF PAC’s COM2 to communication with the

Modbus Master) and then click

Imst_MBSLAVERTL
Rz M MBSLAYERTL &
\ HpoRT
N
‘CTOMZ:9600M 8.1 v | %
#3 Yariables: [all) A/ F
- Inst_BLINK
B[ Inst_MBSLAVERTU
By LED1
B I Fmo b
Yariables: [all] "
[ Local wariables anly
[ ] Hide FB instances

to complete the settings.

Press the “F1” key on this
function block to show up
the related Help.
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4. Double-click the left side of the “SLV” and then enter “1” (the value set in the Section 1.1 - Step 3),

then click ¥ to finish the setting.

Inst_MESLAVERTU
F2 I MESLAVERTL @ |
'COMZ9E00,M,5,1' |PORT
1 4
#3 Yariables: [all) .
y\ SLY @[ Inst_BLINK
&[] Inst_MBSLAVERTU
By LED
Bi |FM2 A
Varables: (al) v|
(RN ol B
Inst_MBSLAVERTU —
F2 I WMBSLAVERTL & |

COM2:9500 M S 1 PORT

Now, you have completed the setting of the “MBSLAVERTU” function block, and then re-compile the
program and download it to the Win-GRAF PAC.

Note: Users can enable multiple Modbus RTU Slave ports for each PAC (recommend not over 16 Ports),
the way is to add multiple “MBSLAVERTU” function blocks and set the different “Port” value.

Win-GRAF PAC

SCADA / HMI
67 - COM2: RS-232
& InduSoft “"‘__h 9600,N,8,1

h << —
@ Slave number =1

Modbus RTU Master

InduSoft

WP-5xx8-CE7 WP-8xx8
Modbus RTU Slave
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1.2.2. Add the “MBSLAVERTUEX” function block

When using several “Server - ...” settings (recommend to set one) in the “IO Drivers” window, the user
needs to use the “MBSLAVERTUEX” function block.

10 Drivers *

M ame | Walue

2 number = 1 Slave number 1

) "B [rnput 2000] - Read_Walue Server D "Swrl'
E “B Input Bitz [1..2000] - Read_Boolean
__'- L
Fequest | Address | Mb Itemn | Description
E Input Registers 1 2000 Read Yalue
|nput Bits 1 2000 Fead_Boolean

=1
4 ¥ FAC Time ‘wariables LD

1. Follow steps 1to 4 above to add the “MBSLAVERTUEX” function block. If you want to change the
usage for existing function block, mouse double-click the “MBSLAVERTU” and change it to
the“MBSLAVERTUEX”, and then click the “OK” button.

Imst_MBSLANERTL
F2 I MBESLAVERTU @

'COM2: 9800 ME 1 JPORT T LOADSTRING [*Get a sting from a table?] ~
IF LOBYTE [*Low part of a word®]
\ It LOG [*Logarithm [base 10)7]
LOGFILECSY [*Generate log file in C5W Format™]
T+ LOGL [Logarithm [baze 10 - LREAL))
T} LOGMESSAGE [*send a LOG meszage?)
I+ LOWORD [*Low part of a double ward®)
=k MAKEDWORD [*Pack words to double word®]
Function ’MKEWDHD [*Pack bytes to word®) -
[T MAX [*M aximum™]
MEMASTERRTU [*MODBUS Master RTU*|
MBMASTERTCP [*MODBUS hMazter TCP¥)
TF MESHIFT [*Multibyte shift/rotate®)
TF MBSLAVEIDEMT [*Set MODBUS Slave Device ldentification®]
FE MBSLAYERTLLFMODELS Slave BT [seiall
MBSLAVERTUER [*MODBUS Slave RTU [seniall)

140y

Function Block

b Inputs: l:l [ al's ‘ l [ Cancel
AN
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Note:

“Server ID”.

Rz

R2

"COMZAE00 M 5 1

In=t MRS AWFRTL
| WMBSLAVERTUEX G
—e—]

PORT

5Ly

"COMZ:AE00,M,5,1°

| MBSLAVERTUER 2

PORT

SLY

5D )

~—_

Click the link for more Win-GRAF FAQ;
https://www.icpdas.com/en/fag/index.php?kind=273#840

2. The “MBSLAVERTUEX” has a “SrvID” setting. Double click the left side of the “SrvID” and enter a
needed “Server ID” (using a string format, e.g., ‘Svrl’).

Using the “MBSLAVERTU” function block means the first Modbus Slave setting will be enabled.
Using the “MBSLAVERTUEX” function block means to enable the Modbus Slave setting depends on the

Tips:

Press the “F1” on this
function block to show
up the related Help.

Now, you have finished the settings for the “MBSLAVERTUEX” function block, and then re-compile
the program and download it to the Win-GRAF PAC.
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