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1.  Building First Program – Hello World 

This section will tell you how to build a program for MiniOS7 based controller. 

Before start building the program, we need to figure out that which Operating System 

is being used on your computer, it is related to the process of developing the 

application. 

If you are using a 32-bit Windows system such as Windows XP, please go to Chapter 

1.2 to select the compiler and continue reading. 

However, if you are using any 64-bit Windows system like Windows 7, Windows 8 or 

Windows 10, you will need an emulator, because the C compiler cannot be executed 

on these 64-bit systems directly. 

Please check the following flow chart to understand the process of developing the 

application. 
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1.1.  Downloading DOSBox 

64-bit systems do not support 16-bit programs, 16-bit processes or 16-bit 

components. 

Therefore, if you are running a 16-bit compiler on 64-bit Windows (such as Borland C 

++ 3.1, Turbo C ++ 3.0 or a program compiled by a 16-bit compiler), you may get an 

error message like below photo. 

 

 

 

 

 

DOSBox is an excellent solution for running the C compiler on 64-bit systems. 

DOSBox simulates the environment in which DOS and DOS used to run, including 

memory management and sound configuration, but has the functions of today’s 

computers. 

On this appendix we will show you how to execute the 16-bit compiler. 
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Step 1: Get the DOSBox Installer 

The latest version of the DOSBox installer can be obtained from 

“SourceForge “web site. 

http://sourceforge.net/projects/dosbox/ 

Step 2: Install the DOSBox 

After the installation has been completed, there will be a new short-cut for DOSBox 

on the desktop. 

 

Step 3: Run the DOSBox 

Right-click the DOSBox, and then click “Run as administrator”. 

 

Tips & Warnings 

If you do not execute DOSBox as an administrator, the 

installation of the compiler will fail. 

 

Two windows will be displayed. 

One is the DOSBox Status Windows, 

And another one is the main execution 

window, which virtualizes a DOS 

operating environment. 

  

http://sourceforge.net/projects/dosbox/
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1.2.  Downloading Compiler 

C is prized for its efficiency, and is the most popular programming language for 

writing applications. 

Before writing your first program, ensure that you have the necessary C/C++ compiler 

and the corresponding functions library on your system. 

Step 1: Download compiler 

 Turbo C / C++(Borland Turbo C++ 1.01 (3.5)) 

https://winworldpc.com/product/turbo-c/1x 

 Borland C / C++ (Borland CPP 3.1 and Application Frameworks (1992) 

(5.25-1.2mb)) 

https://winworldpc.com/product/borland-c/30 

https://winworldpc.com/product/turbo-c/1x
https://winworldpc.com/product/borland-c/30
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Step 2: Extract the file and install 

compiler 

After you download the file, unzip it 

Tips & Warnings 

Please rename the folder and move it to “C:\”. 

It will make the following installation steps easier. 

 

Extract all .img files, there will be an “install.exe”. 

 

 

 

 

 

 

 

 

For 32-bit system, you can just execute the “install.exe” and start to install the 

compiler. 

But, for 64-bit system, you have to run this program in DOSBox, check the step 3 for 

more detail. 

The following steps will use “Borland C” as an example. 
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Step 3: Run the install.exe  

For 32-bit system, run the install.exe will be fine. 

Therefore, for 64-bit system, you need to run DOSBox and mounting a drive as a 

specific directory where you extract the files, then execute the “install.exe”. 

To install Borland C++, please type the commands below. 

 

 

 

 

To install Turbo C++, please type the commands below. 

 

 

 

 

Tips & Warnings 

In some cases, the path “C:\” may not able to be mounted. 

Try to type a different path like “C:\xxx”, or mount another disk will be fine. 

 

 

 

 

 

 

mount C C:\BC 

C: 

cd BC3.1 

install.exe 

mount C C:\TC 

C: 

cd TC1.01 

install.exe 
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The following left side photos are screenshots of the Borland C++ installation 

process. 

And the right side photos are screenshots of the Turbo C++ installation process. 

Step 3: Press “Enter” to continue 

 

 

 

 

 

Step 4: Type the drive which the files are located 

 

 

 

 

 

Step 5: Enter the path of the directory that the files are located 
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Step 6: Change directory to C:\ and Start installation 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Step 7: Press any key to continue 
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Step 8: Installation is complete 
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1.3.  Configuring DOSBox 

Edit the configuration file to automatically run the compiler every time the DOSBox is 

executed.  

The following steps will take Borland C++ as an example. 

Step 1: Edit the configuration file of the DOSBox 

The path of configuration file can be found in the Status Windows. 

 

Tips & Warnings 

If you can’t find the configuration file in the location, 

you’ll have to enable the “show hidden files” option in 

the window properties to display the hidden files.  

 

Step 2: Scroll down to the bottom of the configuration file and Type the 

commands to mount the drive and set path 

For example: 

[autoexec] 

# Lines in this section will be run at startup. 

# You can put your MOUNT lines here. 

Mount C C:\BC 

C: 

path C:\BIN 

BC.exe 
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Save the configuration file and restart DOSBox. 

It will automatically execute the compiler. 

 

 

 

Tips & Warnings 

If you want to specify the directoey every time you start the DOSBox. 

Add “CD” command to change the directory. 

[autoexec] 

# Lines in this section will be run at startup. 

# You can put your MOUNT lines here. 

mount C C:\BC 

mount F F:\ 

path C:\BIN 

F:\ 

CD F:\Project 

BC.exe 
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1.4.  Building Program 

There are several APIs for customizing the standard features and integrating with 

other applications, devices and services. 

Before creating the application, ensure them that you have installed. 

 

Here we assume you have installed the Borland C++ under the C driver root folder 

and the iPAC-8000 APIs under the F driver root folder. 

Then create a “Hello” folder for the following demonstrate. 
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Step 1: Run DOSBox and Compiler 

After edit the configuration file, the compiler should be executed automatically. 

Step 2: Select “New” from the “File” menu to create a new source file 

 

 

 

 

 

 

 

 

 

 

 

Step 3: Type the following code. 

Note that the code is case-sensitive. 

#include <stdio.h> 

#include <stdlib.h> 

#include <string.h> 

#include “..\lib\8000a.h” 

/* Include the header file that allows 8000a.lib functions to be used */ 

void main(void) 

{ 

    /* Initiate the 8000a library */ 

    InitLib();    

    /* Print the message on the screen */ 

    Print(“Hello !!\r\n”);    

} 



 

Compiling Programs for MiniOS7 System     Version: 2.2.0      Page: 16 

Copyright ©  2024 ICP DAS Co., Ltd. All Rights Reserved.  E-mail: service@icpdas.com 

Step 4: Save the source file in the Hello folder 

(1) Select “Save” from the “File” menu 

(2) Find the “Hello” folder 

(3) Named the file as “Hello.cpp” 

(4) Cilck“OK” 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Tips & Warnings 

You can write the code with any text editor that you are used to. 
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Step 5: Create a project (*.prj) 

(1) Select “Open project…” from the “Project” menu. 

(2) Find the “Hello” folder. 

(3) Named the project as “Hello.prj”. 

(4) Click “OK”. 
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Step 6: Add the necessary function libraries to the project (*.lib) 

(1) Select “Add item…” from the “Project” menu. 

(2) Add the source file (hello.cpp) and library (8000a.lib). 

(3) Select “Done” to exit 
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Step 7: Set the memory model to large 

(1) Select “Compiler” from the “Options” menu, then select “Code 

generation…”. 

(2) On “Model” option, select “Large”. 

(3) Select “OK”.  

 

 

 

 

 

 

Step 8: Set the Floating Point to Emulation and the Instruction Set to 80186 

(1) Select “Compiler” from the “Options” menu and then select “Advanced code 

generation…”. 

(2) On “Floating Point” option, select “Emulation”. 

(3) On “Instruction Set” option, select “80186”. 

(4) Select “OK”.  
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Step 9: Set the include and library directories 

(1) Select “Directories…” from the “Options” menu . 

(2) On “Include Directories” option, specify the header file. 

(3) On “Library Directories” option, specify the function library file. 

(4) Select “OK”. 
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Step 10: Set Linker Output to [Standard DOS EXE] 

(1) Select “Linker” from the “Options” menu . 

(2) Select “Setting” from the “Linker” menu . 

(3) Set the “Output” as [Standard DOS EXE]. 

(4) Select “OK”. 
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Step 11: Select “Build all” from the “Compile” menu to build the project 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Tips & Warnings 

 The execute file will be named the same as the project name. 
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Step 12: Select “Close project” from the “Project” menu to close the project 

Close the project before exit DOSBox or Compiler. 

The project file will be generated after the project is closed. 

 

 

 

 

 

 

 

 

 

Tips & Warnings 

Do not click the “X” at the right-top corner of the window before you close 

the project. 

Otherwise, the project will not be generated or saved. 
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Step 13: Create an autoexec.bat file 

(1) Open the “Notepad” 

(2) Type the “HELLO.exe” 

(3) Save the file and named it as autoexec.bat 
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Step 14: Upload programs to controller using MiniOS7 Utility 
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2.  Rebuilding Demos 

Every MiniOS7 product provide its own demos, they can be download in the product 

website, the following steps will show you how to download and rebuild them, this 

section will take the demos of iP-8411 as an example.. 

Step 1: Download Demos 

Go to the ICP DAS website and search for “iP-8411”. 

 

 

 

 

 

 

Click “DOWNLOAD CENTER” butter In the middle of the iP-8411 product website. 

 

 

Stroll down to the “SDK” table and click the picture of magnifier. 

 

 

 

Then, download demos. 
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Step 2: Open Project 

After downloading the demo, unzip it to the location set in DOSBOX profile, it will be 

easier for operating. 

Tips & Warnings 

In my case, I have installed Borland C++ to disk C, and mounted C as location 

“C:\BC”, mounted F as location “F:\”, please refer to Page 11 for more 

detail. 

 

Here we take F:\Project\IP_8000_Series_Demo\Basic\iP-84x1_iP-88x1\Hello\Hello_C 

\HELLO.PRJ as an example, and use BC.exe to open the example. 

 

 

 

 

 

Tips & Warnings 

In the DOSBox environment, the name of a folder or file has a length limit, 

and once it exceeds the name displayed on the window, it will be 

abbreviated. 
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Step 3: Rebuild Project 

Normally, those demos are totally functional, 

The code has been completed and the project has been set up as well. 

But, if you build it, you may get errors like following photos. 

 

 

 

 

 

 

It is because the “Include Directories” and “Library Directories” are wrong for 

your Borland C. 

They can be found in the “Options -> Directories…” of the tool bar. 

Change these directories to the path where you have installed Borland C and 

mounted in DOSBOX. 
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In my case, the right directories are “C:\INCLUDE” and “C:\LIB”. 

 

 

 

 

 

 

After changing the path, rebuild the project and it will succeed. 
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Tips 

1. For develop application, 

Use a text editor instead of the BC/TC user interface; it will be more convenient to 

write code. 

EX: notepad ++.exe  
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