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How to communicate between InduSoft local HMI and ISaGRAF
PACs via Modbus TCP protocol

Application Diagram:
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This document ~ ISaGRAF demo project and InduSoft project can be downloaded from the following
website :
https://www.icpdas.com/en/fag/index.php?kind=280#751 > FAQ-140

For more detail about designing InduSoft HMI, please refer to the following website:
http://www.icpdas.com/en/download/index.php?nation=US&kind1=6&kind2=17&model=&kw=Indusoft
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Application introduction :

This document will show user how to design an InduSoft local HMI to communicate with ISaGRAF PACs
via Modbus TCP protocol.

1.1 : Restore the ISaGRAF demo program ”Soflogic.pia” to PC / ISaGRAF

The fag140_demo_chinese.zip contains one ISaGRAF demo program (Soflogic.pia). Please restore it to
the PC ISaGRAF. Then user can refer to it easily.

| ) 152GRAF - Project Management [E=TEn>]
File Edit Project Options Help T — Projects [
[nED
Libraries Common d E “Workbench Archive
mm creation demo_7E
m d0429 ImportIL program \ el v o
m demo_18 PID control test fhuz m
m demo_41 Record Alarm (text) to S256/512 & PC can load it by ICF I fhuz sl Restore
o | A3 - T~ Ll & b il il - HH
f E&fﬁ:nce K com?2_tes = !?024 Clase
; — =R
|| Date of creation : 2009412429 modbus
|| Version number 1 -ISaGRAF 3.55 il retain Help
Description retaitiva —
L 756
LI " df
F ISaGRAF - Project Management =11 [} -
File Edit Project Tools Options Help saflogic = ' Compress
: = Archive lacation
llBe|bEn X&)t s = | #oem
CHUSERSAGRADYSDESKTORY Browsze
w107
xwhi9
sdf
wdemo_48 VB net 2005 demo - "MBTCP_demo” (www.icpdass. cor
demo_43d 5MS demo, Please declare your own phone No. in the d
demo_76 GPRS demo, Send network packet via GPRS
| soflogic | =
Reference : SofLogic =
Author : _

Date of creation : 2011/5{10
¥Yersion number : 1 -15aGHRAF 3.55
Description

Version for ICP-DAS i-7188/-8000/View/Wincon series controllers only

If user are not familiar with ISASGRAF programming, recommend to refer to the Chapter 2 of the “ISaGRAF User’s
manual” to learn how to write a simple program.

The PDF manual is the “user_manual_i_8xx7.pdf” which can be found in the CD-ROM delivered with the ISaGRAF
PAC or downloaded from the following website.
http://www.icpdas.com/en/download/show.php?num=333&nation=US&kind1=6&kind2=8&model=&kw

=isagraf

ISaGRAF PACs data sheet:
http://www.icpdas.com/en/download/index.php?nation=US&kind1=6&kind2=15&model=&kw=isagraf
If user doesn’t have the standard version of ISSGRAF workbench, please refer the following website to install the

trial version of it.
https://www.icpdas.com/en/fag/index.php?kind=280#751 >FAQ-139
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1.2: How to test this demo
1. Execute the WinPAC Utility in the WP-8447, then click the tab of “Ethernet Setting” to set network

environment.

IP :192.168.1.232
Mask : 255.255.255.0

Then, click the “Setting” button and click [File] > [Save and Reboot] on tool bar. Then the new registry
will be applied after the WP-8447 rebooting.

]
B
7]

WInPAC Utility [2.0.2.1]

File Help Configuration

Systern Setting ‘ Ethernet Setting | MNetwork Setting lSystem Infor mation ]Auto Execution ] Multi-serial| <

LANL | Lan2

MAC Address 1; 00-00-E0-30-02-34
LAN 1 IP Address Setting:
(T Use DHCP o get IP address

(@) Assign IF address

IP Address: 192.168.1.232
Mask ! 255.255.255.0
Gateway: 0.0.0.0

DMS Server:

‘;ﬁ, 10:57 AM ‘ﬁ|%

£9| | WinPAC Utility [2.0.2.1]

2. Open the ISaGRAF demo program “Soflogic”, compile it and download it to the WP-8447.

~— |Click this icon to set link setting.

1 |=

= s

ISaGRAF - SOFLOGIC - Programs

Communication port:

Corntral

Tinie out [zecands]:

Setup

ETHERNET | Cancel
2
1
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3. Open the InduSoft demo project “PC_HMI”

The fag140_demo_chinese.zip contains one InduSoft demo project (PC_HMI). Click the file
“PC_HMI.APP” in project folder to open it.

InduSoft Web Studio - [Displawl]

Click this icon to run the application

File Edit View I[nsert FProjged” Tool: Window Help
A w & o[
> @D 42
®
= ¥ Project: PC_HMI APP
[ Sereens
["7] WFroup Bereen

HMI manual:
1. Set the cooling process time to the “process time"

column. [mawaon | [ wewaor | .
2. Set the maximum temperature : Fan RFM | ) |

Fill the maximum temperature in the “Maximum System status

temperature” column. If the current temperature is Process Time | oo mos |

E\F;er this temperature, the cooling process will start Elapsed Time | Raaumo |
3. Click the “Manual On” button to start up the cooling Maximum temperature | wo c |

process manua"y' Process Operating
4. Click the “Manual Off” button to shut down the Current temperature | 00000 c

cooling process manually.
5. The “Process operating lamp” is green during cooling
nrocess.

4. If the communication between HMI and ISaGRAF PAC is good, the “System status” lamp is green. If it is
bad, the “system status” lamp is red.

Or user can check the communication quality good or bad from the tag in the window of Database Spy. If
the quality is bad or the “system status” lamp is red, please recognize whether the WP-8447 and PC are
in the same Domain and the network wire is connected or not.

. Name Waluz Cality | Continuons |

DI[0] I GOoD
DI[1] 0 300D
Timer[0] 120000 GOCD
Timex[1] i GOoD
Temperatorel Q000  GooD
Temperature Q000  GQoD

] O

< ».DB1/DEZ »DE3 5 DE4 /
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5. The “Process operating” lamp is green during the cooling process, and HMI will show how long the
time of the process is passing by in the column of Elapsed Time.

[ manual on || Manual Off |

System status

Process Operating

Fan RPM | 24084 ‘

Process Time | oh2mos |

Elapsed Time |

0. h & mdd=s ‘

Maximum temperature | 900 C ‘

Current temperature | 0.0000 © ‘

6. User also can observe the variables in the Spy list of ISSGRAF Workbench synchronously to recognize
that the cooling system is working or not.

When the

cooling system starting up :

1. The value of DO1 is True to turn the solenoid valve ON for spraying water.
2. The value of AO1 will output continuously to control the RPM of fan.
3. Timer2 is ticking.

B

File Edit

DR&|=Mw=a)

Mame

D2
Tempersture
Temperature
Timer1
Timer2

pate|

Al

=end of list=

. I5aGRAF - SOFLOGIC:LISTI1 - List of variables

Optionz  Help

Comment
FALSE
FALSE
TRUE
FALSE
0
=]
t#2m
t#4=461ms
2436
0

1

N
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1.3: Create an InduSoft project

1. Select [File] > [New] from the tool bar of InduSoft studio

Indufoft Web Stodio - [Dasplayl]

File | Edit View Inst Project Tools Window ]
2] Hew.. CtlN | S [

([ Open Project...

& OpenFie... Ctl+D :I
Cloze Ctl4Fa E—

=l L)

2. Select the Project tab in the new dialog, and specify a Location, a Configuration file and a Target
platform

Input “PC_HMI” in the Application name text box and select “NTViewPRO”.
Finally, click “OK” button.

Fils Project |

Application pame:
PC_HMI - |

Location:
|C:".Dn:n::1.umnts and Setﬁngs‘ﬂtepm Dacumentsilnd nioft Web St [ Browese ]

Configuration file:
|CZ".DDI3'IJm.E]1tS and Settings'Stephen'tdy Documents\lnduioft Web Stﬁfqvﬁ.l P1'-|
N

Targzet platform:

CEView Lite CEWiew PEO Control Room
CEView Lite Pluz T 1enw PE Sdvanced Server
Lite Interface
CEWView Standard

fiEE RTiH
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3. Specify the resolution of screen

Specify the resolution to 800*600. Click OK to close the Project wizard dialog.

Project Wizard §|

Template: Diso
Empty Application "P ay.
Fezolution;

1366x768 v

Cusztom

240 % 320
320 240
G40 » 240
G40 » 480

800« 600

1024 » 7E8

1152 » 768

1152 » 8R4

1280 » B8 \

Shared Tags 1280 % 800

1280 %8594 \
1280 % 1024
1366 760
1440 % 360
1400 % 1050
1600 % 900
1600 %1200

1600 %1024
0K 11680 £ 1050

19081200 |

043 % 1536

0% 1600
3340 = 2400

| —
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Select the Database tab in the Workspace pane. Expand the Application Tags folder and right-click the
Datasheet View icon. And then select the “Open" to open the Application Tags window in the pop-up

menu.

= 9% Project: PC_HMI APP
=-£5 Application Tags
E Datazheet Wiew

(] TagList (I '\
[ Clazes
+-{_7 Shared databass

+-_7) Swstemn Tags
+-{17] Becurity
[C7] Global Proceduyes
Event Settings

1. Use the following information to complete the fields on this window.

Mame Size | Type |
1 o 5 Boolean v
2 |Hlpo 5 Boolean v
3 |[=ao 5 Integer v
4 (=] Tirmer a Integer ¥
5 ([T Hour 2 Integer v
5 L™ Minute1 i] Integer v
7 L gecond? i] Integer v
8 @Temperaturm 0 Real hd
] E% Ternperature ] Real v
- Integer A
* Intarar A"
4
Tag name Array size Type Description
DI 5 Boolean DO in ISaGRAF
DO 5 Boolean Dl in ISaGRAF
Al 5 Integer AO in ISAGRAF
Timer 5 Integer Timer in ISaGRAF
Hourl 0 Integer Internal
Minutel 0 Integer Internal
Second1l 0 Integer Internal
Temperature 0 REAL Current Temperature
Temperaturel 0 REAL Maximum temperature
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1.5: Create the Modbus TCP worksheet

1. Inthe Workspace panel, select the Comm tab. Expand and right-click the “Drivers” folder. And then
select the “Add/Remove drivers” in the pop-up menu to open the Communication Drivers dialog.

=
= 3% Project: PC_HMI.APP
g g?d Add/Remove drivers RJ
[0 TCPRAR \
(] DDE

B koo @ Pox _

2. Click the MOTCP driver in the list of Communication drivers. Then Click the “select” button.
Communication Drivers §|

Available drivers:

DLL D'eszcription *'\l Help |

MODEU  MODEUS Protocol BT UAASCI (MT-2000-9%-CE] [+10.3]
MODPL  MODEUS PLUS Protocal [MT-98] [+1.08]

MODSL Frotocol ModBus Slave[ASCH and RTU][Senal and TCPA...
MOLDW  MOLOYW Protocol RTUAASCI [MT-2000-92) [+1.00]
A0 TC MODEUS Protocol BTU wia TCPAP [MT-2000-9%-CE] [+
P SIEMEMNS, MPI Protocol - 57 [MT-98] [+1.29)]
FPIAD SIEMEMS. MPI Green Cable Protocol - 3964F [MT-2000-9..
FPRF SIEMEMS, MPI Protocol [HMI kMPI70) - S7-200, S7-300, 5.

MTRAC  SEW - Movirac31(NT-2000-3) [1.00] v
Selected drivers:
DLL Dezcrnption

| o ,e | Cancel
\
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Communication Drivers @

Avalable drivers:

DLL

4381B
3154
A2420
A280
AR00
ARCIP
ABEMI
ABKE
ABTCP

Dezcription

Agilent, High-Performance Device [MT 2k =1 [1.00]
3154 - Contraller 3154, Toledo Balance (32T 26 [+1.00]
ALTUS, ALMET | Protocol with ALZ2420 [MT-2000-9x) [+1.04]

Diriveer for A260 Equiprnent [Ta/MT /2K [+1.26]
WEG - AR00 [MT-2000-9x] [+1.02]

Allen Eradley YEthernet CIF Protocol [3x/M T A20005PACE)..
Allen Bradley, AB-1761-MET-ENI Gateway interface [MT-20...
Allen Bradley, DF1 Protocaol [PLCZ, PLCS and SLCR00) Fa...
Allen Bradley Ethernet, DF1 Protocaol [FLCZ, PLCS and SL...

" Select »>

Selected drivers:

DLL
MOTCP

Dezcription

MODEUS Protocol BT wia TCP/P [NT-2000-92-CE]

»» Remove

| ok ,{[ Cancel |
N

= 9% Project: PC_HMI APP
=43 Drivers
= £ MOTCE
& MAIN DRIVER SHEE
{3 CEC
[ TCRAP
(] DDE
<
B oo B o B o e [
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3. When the MOTCP driver show in the “Selected drivers” list, please click the “OK” button to close the

4. Select the Comm tab in the Workspace, expand the MOTCP folder. And double click the “main driver
sheet” icon to open worksheet.
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5. Use the following information to complete the fields on this work sheet.

[l MOTCE - |

Diescription:

Dizable:

Fiead Completed:

Read Status:

i3

‘wirite Completed: ‘wirite Status: O
Tag Mame Station | I Address Actic

1 |Do[0) 182.168.1.232:502:1 01 Read+rite
T Do) 182.168.1.232:502:1 02 Read+rite
TTimer[D] 182.168.1.232:502:1 D41 Read+rite
TTimer[ﬂ 182.168.1.232:502:1 D343 Read+rite
T Do) 192.168.1.232:5021 TH1 Read+ifrite
?AO[D] 192.1681.232:5021 Ernch] Read+irite
?Temperatur... 192.168.1.232:502:1 FP3:51 Read+\rite
T Termperature 1821681 232:5021 FP:A3 Read+rite

* Read+rite

The map of Modbus address of the Open variable in the ISSGRAF PAC:

Variabl
ariable Type Address Comment
name
DI1~DI5 Boolean 1~5 Internal variables to trigger or stop the cooling process
DO1~DO3 Boolean 11~13 Control the channel 1~3 of I1-8057
DO4 Boolean 14 Check the state of communication between HMI and
ISaGRAF PAC
DO5 Boolean 15 Control the channel 4 of I-8057
Al1~AI5 Integer 21~25 The state of the channel 1~5 of 1-87018
AO1~AO5 Integer 31~35 Control the channel 1~4 of 1-8024
Timerl Integer 41 The time of total process
Timer2 Integer 43 Elapsed time

ICP DAS Co., Ltd. Technical Document
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The map of tags :
Tag Name station I/0 address
DO[0] 192.168.1.232:502:1 0X:1
DO[1] 192.168.1.232:502:1 0X:2
Timer[0] 192.168.1.232:502:1 DW:41
Timer[1] 192.168.1.232:502:1 DW3:43
DI[0] 192.168.1.232:502:1 1X:11
AO[0] 192.168.1.232:502:1 4X:31
Temperaturel 192.168.1.232:502:1 FP3:51
Temperature 192.168.1.232:502:1 FP:53
DI[4] 192.168.1.232:502:1 1X:14

The detail information of the Column Field Name :

® Tag Name: a tag name for communication driver to use

®  Station: the equipment station number within the network.
Please refer to the following syntax to fill in this field

<IP address>:<Port Number>:<Slave ID>
IP address: the IP address of the Modbus device
Port Number: the port number for the Modbus TCP protocol(usually 502)

Slave ID: the slave ID of Modbus device

EX: ISaGRAF PACIP : 192.168.1.232, TCP Port : 502,
Slave ID(Number) : 1

192.168.1.232:502:1

® |/O address: the Modbus address of the associated device register.
Please refer to the following syntax to fill in this filed

<Type>:<Address>
Type : Register type

The map of the type to Read/Write open variable in ISSGRAF PAC

ISaGRAF variable Type
Read Boolean 1X
Read and write Boolean 0X
Read integer 3X
Read and write integer 4X
Read long integer DW3
Read and write long integer DW
Read Timer DW3
Read and write Timer DW
Read real FP3
Read and write real FP

ICP DAS Co., Ltd. Technical Document
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Address : Address of the device register(in Decimal)
EX: Address of the device register : 41, read a timer variable

I/0 address > DW3:41

For more detail about designing InduSoft HMI, please refer to the following website:
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http://www.icpdas.com/en/download/index.php?nation=US&kind1=6&kind2=17&model=&kw=Indusoft
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