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Chapter 8 Connecting DCON I/O Modules 

The Win-GRAF PAC can connect the ICP DAS "I-7000" and "I-87KW" remote DCON I/O modules via the 

COM Port (RS-485). Each PAC can enable up to 16 DCON Ports, and each Port can connect up to 50 

remote DCON I/O modules (not recommended over 32). If select the "I-87KW" series I/O modules, it 

must be used with the RS-485 I/O Expansion Unit (e.g., I-87K4/5/8/9 or RU-87P4/8). You can view the 

detailed product information on the ICP DAS website:  

http://www.icpdas.com/root/product/solutions/remote_io/remote_io_products.html 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Before connecting "I-7000" or "I-87KW" remote DCON I/O modules, you must use "DCON Utility" 

software to configure each module for the Protocol (choose DCON mode), Address (1 ~ 255), Baudrate 

(the setting must the same with the Win-GRAF PAC, recommended set to 9600), Checksum (the setting 

must the same with the Win-GRAF PAC, recommended set to "enabled" for communications security), 

Data format and other Input/Output settings (set according to demand). 

 

Note: 

A. When using the AI module of I-7000 and I-87KW, set the Data format to "2's Complement". 

E.g.  I-7005, I-7013, I-7014D, I-7015, I-7016, I-7017R, I-7018Z, I-7019R, I-7033;  I-87005W, I-87013W, 

         I-87015W, I-87015PW, I-87016W, I-87017W, I-87017RCW, I-87017ZW, I-87017DW, I-87018W,  

         I-87018RW, I-87018ZW, I-87019RW, I-87019ZW, and other Analog Input modules.  

B. When using the AO module of I-7000 and I-87KW, set the Data format to "Engineering" 

 E.g. I-7021, I-7022, I-7024, I-7024R;  I-87024W, I-87024UW, I-87024CW, I-87028UW, I-87028CW, 

         I-87028VW, I-87028VW-20V, and other Analog Output modules.  

 

"DCON Utility" is an easy-to-use software toolkit that help user search the network, configure the I/O 

modules and test the I/O status. Please visit the website to get the software program and user manual:  

www.icpdas.com/products/dcon/introduction.htm  

 
 
The following will introduce the setting method in the Win-GRAF Workbench. 

 
 

http://www.icpdas.com/root/product/solutions/remote_io/remote_io_products.html
http://www.icpdas.com/root/product/solutions/remote_io/rs-485/i-7000_m-7000/i-7000_m-7000_selection.html
http://www.icpdas.com/root/product/solutions/remote_io/rs-485/i-8k_i-87k/i-8k_i-87k_selection.html#b
http://www.icpdas.com/root/product/solutions/remote_io/rs-485/i-7000_m-7000/i-7000_m-7000_selection.html
http://www.icpdas.com/root/product/solutions/remote_io/rs-485/i-8k_i-87k/i-8k_i-87k_selection.html#b
http://www.icpdas.com/products/dcon/introduction.htm
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8.1 Setting "DCON" I/O Boards 

"DCON" can be used to enable an RS-485 Port to connect remote DCON I/O modules (e.g., I-7000 series 

modules, RU-87P8 I/O Expansion Unit + I-87KW I/O modules, or I-87K8 I/O Expansion Unit + I-87KW I/O 

modules). If want to enable more than one DCON Port, please set up multiple "DCON" I/O Boards. (One 

PAC can enable up to 16 "DCON".) 

 
1. Click "Open I/Os" of the Win-GRAF tool bar to open the “I/O Boards” setting window. 

 
 
 
 
2. Double click "Slot8" to add "DCON" I/O Boards (Refer to Chapter 4), and then double click "DCON" to 

open the “Properties” window. 

Note: The Slot 0 to Slot 7 are reserved for real I/O modules that plugged into the PAC, and the slot 8 

or above are for other usage.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Parameters: 

Note:  This "DCON" supports only the communication properties "N,8,1". That is "No-parity" , "8 

character size" and "1 stop bit" . So please must configure all DCON I/O modules to "N,8,1". 

 

Port:  COM port number (1 ~ 37, depends on the PAC.) 

Baud_rate:  Communication baudrate in bps, can be 1200, 2400, 4800, 9600, 19200, 

38400, 57600, 115200 (bps). Set a wrong value will use the default value 

9600.  

Host_watchdog_Enabled: 1: enable host-watchdog, 0: disable it. 

Set a nonzero value will use the value 1. 

Setting Descriptions 
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Watchdog_timeout:  Unit: ms, can be 3000 ~ 25500. 

Set larger than 25500 will use 25500 ms (25.5 sec). 

Set smaller than 3000 will use 3000 ms (3 sec). 

Ignore this setting when "Host_watchdog_Enabled" is 0. 

Checksum_enabled:  0: disabled, 1: enabled. 

Set a nonzero value will use the value 1. (Recommended set to 

"enabled" for communications security.) 

Delay_ms_between_polls:   Unit: ms, default is 0 ms. Valid range is 0 ~ 1000.  

Set smaller than 0 will use 0 ms.  

Set larger than 1000 will use 1000 ms. 

If there is no wireless module connected, set a smaller value. 

       For instance, set as 0 ~ 10. 

If there are wireless modules (e.g., ICP DAS ZigBee Products: ZigBee 

Converters or ZigBee I/O modules.) connected, set a bigger value. 

       For instance, set a value between 30 ~ 100 or other values.  

Set larger value will get slower polling efficiency. 

 
Double click the item to be set, and then fill in the value. 
 
 
 
 
 
 
 
 
 
 
 
 
3. After setting up the "DCON" in the "I/O Boards" window, it will automatically add a "BOOL" input 

variable in the "Variables" window. When the Win-GRAF links to the PAC, it will show the COM Port 

communication status (TRUE: OK; FALSE: error.). 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

http://www.icpdas.com/root/product/solutions/remote_io/remote_io_products.html#ZigBee
http://www.icpdas.com/root/product/solutions/remote_io/remote_io_products.html#ZigBee
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8.2 Using I/O Function Blocks 

The Win-GRAF supports many ICP DAS DCON remote I/O modules, you can open the "Library Manager" 

(Refer to Section 1.2.3) or press "F1" key in the "Function and FBs" to view these I/O Function Block 

descriptions. This section will introduce "D_7065", "D_7018Z", "D_7083", "D_87084_freq", 

"D_87084_cnt4", "D_87084_cnt8", and "DL_100T485" I/O Function Blocks. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
In the LD Program - Functional Block area, expand the "ICP DAS - XP-WP-VP" folder of the "Blocks" panel. 
There are many Functions and Function Blocks. You can select the desired one, and drag it into the 
editing area of the program. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Tips:   
Press “F1” to see the setting description. 
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8.2.1 “D_7065” Function Block 

“D_7065”:  Connect a remote I-7065, I-7065D (Power Relay Output Module) or I-7065A, I-7065AD, 

I-7065B, I-7065BD (Solid State Relay Output Module). 

 

Note:   

1. All connected DCON I/O modules should be configured once by the DCON Utility (refer to P8-1). 

2. Please use "DCON"(Section 8.1) in the "I/O boards" window and set proper settings (Port, baud_rate, 

etc.) on it. 

3. All values of DI channels are meaningful only when the returned communication state is TRUE (If 

"OK" returns "TRUE".). 

4. Refer to Chapter 12, click the menu bar "File" > "Add Existing Project" > "From Zip" to restore the 

demo project (CD-ROM: \Napdos\Win-GRAF\demo-project\DEMO_D_7065.zip) in the shipping CD and 

view the program and descriptions. 

 
Supposition: Use PAC‘s COM2 to connect the I-7065 (Addr. = 2) with 4 DI and 5 Relay output channels. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Input Parameters: 

EN:  Data type: BOOL. TRUE: enable it; FALSE: disable it. 

Port:  Data type: DINT. COM port number (can be 1 to 37, depends on PAC). 

(*** Must use a constant value, cannot be a changed value. ***) 

Addr: Data type: DINT. The Net-ID address of the module , can be 1 to 255. 

(*** Must use a constant value, not a changed value ***) 

RL_1 ~ RL_5: Data type: BOOL. 5-Ch DO values. 

 

Output Parameters: 

OK:  Data type: BOOL. TRUE: Communication is Ok. FALSE: Communication failed. 

IN_1 ~ IN_4:  Data type: BOOL. 4-Ch DI values. 

 

 
 
 
 

If "OK" returns "TRUE". 

Declare 9 BOOL variables 
(DI & DO of the I-7065). 

http://www.icpdas.com/root/product/solutions/remote_io/rs-485/i-7000_m-7000/selection-digital_io.html#f
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8.2.2 “D_7018Z” Function Block 

“D_7018Z”: Connect a remote I-7018Z module that is a 10-channel Thermocouple analog input module 

for measuring voltage, current or temperature with features of individual channel 

configuration, open-wire detection and over Voltage protection.  

 
Note:   

1. All connected DCON I/O modules should be configured once (e.g., Address, Baudrate, etc.) by the 

DCON Utility (refer to P8-1). Please must configure the data format of AI modules to "2’s 

complement" by DCON utility, or the Win-GRAF PAC can not read them well. 

2. Please use "DCON" (Section 8.1) in the "I/O boards" window and set proper settings (Port, baud_rate, 

etc.) on it. 

3. All values of AI channels are meaningful only when the returned communication state is TRUE (If 

"OK" returns "TRUE".). 

4. Refer to Chapter 12, click the menu bar "File" > "Add Existing Project" > "From Zip" to restore the 

demo project (CD-ROM: \Napdos\Win-GRAF\demo-project\DEMO_D_7018z.zip) in the shipping CD and 

view the program and descriptions. 

 
Supposition: Use PAC‘s COM2 to connect the I-7018Z (Addr. = 3) to measure the Celsius temperature. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Input Parameters: 

EN:  Data type: BOOL. TRUE: enable it; FALSE: disable it. 

Port:  Data type: DINT. COM port number (can be 1 to 37, depends on PAC). 

(*** Must use a constant value, cannot be a changed value. ***) 

Addr: Data type: DINT. The Net-ID address of the module , can be 1 to 255. 

(*** Must use a constant value, not a changed value ***) 

If "OK" returns "TRUE". 

Declare 10 REAL variables 
(AI of the I-7018Z). 
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Tmp_F:  Data type: DINT. Temperature Format, can be 1 or 2: 

1 : temperature unit in Degree Celsius. 

2 : temperature unit in Degree Fahrenheit. 

Other value: use it as "1:temperature unit in Degree Celsius". 

 
Output Parameters: 

OK:  Data type: BOOL. TRUE: Communication is Ok. FALSE: Communication failed. 

V_0 ~ V_9: Data type: REAL. 10-Ch AI value. 

If the channel range type is configured as mV or Volt by DCON utility, the unit of the 

returned channel value is Volt. 

    For example, 0.85421 means 0.85421 V or 854.21 mV. 

If the channel range type is configured as mA by DCON utility, the unit of the 

returned channel value is mA.  

    For example, 1.5567 means 1.5567 mA . 

If the channel range type is configured as temperature, the value unit is degree.  

    For example, 25.75 means 25.75 degrees. 

 
 
Open-wire Detection: 

If the returned temperature is greater than "9000.0", it means that 

1. The temperature sensor may be broken-line. 

2. The temperature sensor may be broken. 

3. The DCON module is not configured well to fit the connected temperature sensors. 

4. The ohm measured by the connected sensor is not correct. 
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8.2.3 “D_7083” Function Block 

“D_7083”: Connect a remote I-7083, I-7083D, I-7083B or I-7083BD module that is a 3-axis, 32 bits 

encoder counter.  

 
Note:  
1. To get the Encoder value of the I-7083, I-7083D, I-7083B and I-7083BD module, first using "D_7083" 

Function Block. Then, using the “Counter_Start”, “Counter_Stop”, “Counter_Get”, “Counter_State” 

and “Counter_Reset” Functions (Refer to Section 4.9) to operate encoder channels in an I-7083, 

I-7083D, I-7083B and I-7083BD module. 

2. All connected DCON I/O modules should be configured once (e.g., Address, Baudrate, etc.) by the 

DCON Utility (refer to P8-1). Please must configure the data format of AI modules to "2’s 

complement" by DCON utility, or the Win-GRAF PAC can not read them well. 

3. Please use "DCON"(Section 8.1) in the "I/O boards" window and set proper settings (Port, baud_rate, 

etc.) on it. 

4. All values of AI channels are meaningful only when the returned communication state is TRUE (If 

"OK" returns "TRUE".). 

5. Refer to Chapter 12, click the menu bar "File" > "Add Existing Project" > "From Zip" to restore the 

demo project (CD-ROM: \Napdos\Win-GRAF\demo-project\DEMO_D_7083.zip) in the shipping CD and 

view the program and descriptions. 

 
Supposition: Use PAC‘s COM2 to connect the I-7083 (Addr. = 4) with 3 DI channels. 
 
 
 
 
 
 
 
 
 
 
 
 
 
Input Parameters: 

EN:  Data type: BOOL. TRUE: enable it; FALSE: disable it. 

Port:  Data type: DINT. COM port number (can be 1 to 37, depends on PAC). 

(*** Must use a constant value, cannot be a changed value. ***) 

Addr: Data type: DINT. The Net-ID address of the module , can be 1 to 255. 

(*** Must use a constant value, not a changed value ***) 

 
Output Parameters: 

OK:  Data type: BOOL. TRUE: Communication is Ok. FALSE: Communication failed. 

Z_0 ~ Z_2: Data type: BOOL. 3-ch Z-index DI value. 

 
 
 
 

If "OK" returns "TRUE". 

Declare 3 BOOL variables 
(Z-index DI of I-7083). 

To read/write/operate 
Encoder, see Section 4.9. 
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8.2.4 “D_87084_FREQ” Function Block 

"D_87084_freq": Connect a remote I-87084W in an I/O Expansion Unit (e.g., I-87K4/5/8/9 or RU-87P4 or 

RU-87P8.) to measure 8-ch frequency. 

Note:  

1. Please MUST configure the I-87084W's frequency data format as "Hex format" by DCON utility (refer 

to P8-1) when using the I-87084W to measure frequency. Or it will not work. 

2. Please use "DCON"(Section 8.1) in the "I/O boards" window and set proper settings (Port, baud_rate, 

etc.) on it. 

3. All values of AI channels are meaningful only when the returned communication state is TRUE (If 

"OK" returns "TRUE".). 

4. Refer to Chapter 12, click the menu bar "File" > "Add Existing Project" > "From Zip" to restore the 

demo project (CD-ROM: \Napdos\Win-GRAF\demo-project\DEMO_D_87084_FR.zip) in the shipping CD 

and view the program and descriptions. 

 
Supposition: Use PAC‘s COM2 to connect the I-87084W (Addr. = 5) to measure 8-ch frequency. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Input Parameters: 

EN:  Data type: BOOL. TRUE: enable it; FALSE: disable it. 

Port:  Data type: DINT. COM port number (can be 1 to 37, depends on PAC). 

(*** Must use a constant value, cannot be a changed value. ***) 

Addr: Data type: DINT. The Net-ID address of the module , can be 1 to 255. 

(*** Must use a constant value, not a changed value ***) 

 
Output Parameters: 

OK:  Data type: BOOL. TRUE: Communication is Ok. FALSE: Communication failed. 

Freq_0 ~ Freq_7: Data type: DINT. 8-Ch frequency value, unit is Hz. 

 
 
 
 
 

If "OK" returns "TRUE". 

Declare 8 DINT variables 
(frequency inputs of the 
I-87084W) 
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8.2.5 “D_87084_CNT4” Function Block 

"D_87084_CNT4": Connect a remote I-87084W in an I/O Expansion Unit (e.g., I-87K4/5/8/9 or RU-87P4 

or RU-87P8.) to measure 4-ch counters. 

Note:  

1. Please MUST configure the I-87084W's counter data format as "Hex format" by DCON utility (refer 

to P8-1) when using the I-87084W to measure counters. Or it will not work. 

2. Please use "DCON"(Section 8.1) in the "I/O boards" window and set proper settings (Port, baud_rate, 

etc.) on it. 

3. To get the 4-ch counter value from the remote I-87084W, first using "D_87084_cnt4" Function Block. 

Then, using the "Counter_Start", "Counter_Stop", "Counter_Get", "Counter_State" and 

"Counter_Reset" Functions (refer to Section 4.9) to operate counter channels. 

4. All values of AI channels are meaningful only when the returned communication state is TRUE (If 

"OK" returns "TRUE".). 

5. Refer to Chapter 12, click the menu bar "File" > "Add Existing Project" > "From Zip" to restore the 

demo project (CD-ROM: \Napdos\Win-GRAF\demo-project\DEMO_D_87084_C4.zip) in the shipping CD 

and view the program and descriptions. 

 
Supposition: Use PAC‘s COM2 to connect the I-87084W (Addr. = 6) to measure 4-ch counters. 
 
 
 
 
 
 
 
 
 
 
 
 
 
Input Parameters: 

EN:  Data type: BOOL. TRUE: enable it; FALSE: disable it. 

Port:  Data type: DINT. COM port number (can be 1 to 37, depends on PAC). 

(*** Must use a constant value, cannot be a changed value. ***) 

Addr: Data type: DINT. The Net-ID address of the module , can be 1 to 255. 

(*** Must use a constant value, not a changed value ***) 

 

Output Parameters: 

OK:  Data type: BOOL. TRUE: Communication is Ok. FALSE: Communication failed. 

 

 
 
 
 
 
 
 

If "OK" returns "TRUE". 

To read/write/operate 
counter, see Section 4.9. 
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8.2.6 “D_87084_CNT8” Function Block 

"D_87084_CNT8": Connect a remote I-87084W in an I/O Expansion Unit (e.g., I-87K4/5/8/9 or RU-87P4 

or RU-87P8) to measure 8-ch counters. 

Note:  

1. Please MUST configure the I-87084W's counter data format as "Hex format" by DCON utility (refer 

to P8-1) when using the I-87084W to measure counters. Or it will not work. 

2. Please use "DCON"(Section 8.1) in the "I/O boards" window and set proper settings (Port, baud_rate, 

etc.) on it. 

3. To get the 8-ch counter value from the remote I-87084W, first using "D_87084_cnt8" Function Block. 

Then, using the "Counter_Start", "Counter_Stop", "Counter_Get", "Counter_State" and 

"Counter_Reset" Functions (refer to Section 4.9) to operate counter channels. 

4. All values of AI channels are meaningful only when the returned communication state is TRUE (If 

"OK" returns "TRUE".) . 

5. Refer to Chapter 12, click the menu bar "File" > "Add Existing Project" > "From Zip" to restore the 

demo project (CD-ROM: \Napdos\Win-GRAF\demo-project\DEMO_D_87084_C8.zip) in the shipping CD 

and view the program and descriptions. 

 
Supposition: Use PAC‘s COM2 to connect the I-87084W (Addr. = 7) to measure 8-ch counters. 
 
 
 
 
 
 
 
 
 
 
 
 
 
Input Parameters: 

EN:  Data type: BOOL. TRUE: enable it; FALSE: disable it. 

Port:  Data type: DINT. COM port number (can be 1 to 37, depends on PAC). 

(*** Must use a constant value, cannot be a changed value. ***) 

Addr: Data type: DINT. The Net-ID address of the module , can be 1 to 255. 

(*** Must use a constant value, not a changed value ***) 

 

Output Parameters: 

OK:  Data type: BOOL. TRUE: Communication is Ok. FALSE: Communication failed. 

 
 
 
 
 
 
 
 

To read/write/operate 
counter, see Section 4.9. 

If "OK" returns "TRUE". 
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8.2.7 “DL_100T485” Function Block 

"DL_100T485": Connect a remote DL-100T485 module to get humidity and temperature value. 

 
Product website: http://www.icpdas.com/root/product/solutions/remote_io/rs-485/dl_series/dl-100t485.html  

 
Note:  

1. Please use "DL-100T485 Utility" software in the shipping CD to configure the appropriate parameters 

of the module (e.g., Module ID). The TDL-100T485’s default Address (ID) is "1", Baudrate is "9600", 

and the Checksum is "Disable". 

2. Please use "DCON"(Section 8.1) in the "I/O boards" window and set proper settings (Port, baud_rate, 

etc.) on it. 

3. All values of AI channels are meaningful only when the returned communication state is TRUE (If 

"OK" returns "TRUE".) . 

4. Refer to Chapter 12, click the menu bar "File" > "Add Existing Project" > "From Zip" to restore the 

demo project (CD-ROM: \Napdos\Win-GRAF\demo-project\ DEMO_DL_100T485.zip) in the shipping CD 

and view the program and descriptions. 

 
Supposition: Use PAC‘s COM2 to connect the DL_100T485 (Addr. = 1) to get humidity and temperature 

value. 

 
 
 
 
 
 
 
 
 
 
 
 
Input Parameters: 

EN:  Data type: BOOL. TRUE: enable it; FALSE: disable it. 

Port:  Data type: DINT. COM port number (can be 1 to 37, depends on PAC). 

(*** Must use a constant value, cannot be a changed value. ***) 

Addr: Data type: DINT. The Net-ID address of the module, can be 1 to 255. 

(*** Must use a constant value, not a changed value ***) 

 

Output Parameters: 

OK:  Data type: BOOL. TRUE: Communication is Ok. FALSE: Communication failed. 

RH: Data type: REAL. The value is "Relative humidity"; unit is 1%. 

For example, a value "45.7" means 45.7%. 

Temp_C:  Data type: REAL. The temperature value is in "Degree Celsius". 

For example, a value "25.7" means 25.7 Degree C. 

Temp_F : Data type: REAL. The temperature value is in "Degree Fahrenheit". 

For example, a value "78.26" means 78.26 Degree F. 

 

Declare 2 REAL variables 
(humidity and temperature 
values of the DL-100T485.) 

If "OK" returns "TRUE". 

http://www.icpdas.com/root/product/solutions/remote_io/rs-485/dl_series/dl-100t485.html
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8.2.8 “D_GPS721” Function Block 

Using the “D_GPS721” function to link one “GPS-721” remote GPS receiver module (includes one DO 

and one PPS outputs) which is used to receive GPS signals, get the precise date, time, longitude and 

latitude, and for satellite positioning and time correction. Moreover, “GPS-721” is equipped with a 

RS-232 interface,  the remote host can request the GPS-721’s GPS information and remotely control the 

built-in DO channel by using DCON commands over RS-485. And, the PPS (Pulse Per Second) function 

can be used for a simple time synchronization. 
 

Product website: 
http://www.icpdas.com/root/product/solutions/industrial_wireless_communication/wireless_solutions
/gps-721_tc.html 
 

Note:  

1. One PAC can use only one GPS-721 module. 

2. All connected modules should be configured once. First of all, set up parameters of the GPS-721 

module (e.g., Address, Baudrate, etc.) by the DCON Utility (refer to P8-1). (By defaults, the Address 

(ID) is "1", Baudrate is "9600", and Checksum is "Disable".) 

3. Please add "DCON" (Section 8.1) in the "I/O boards" window and fill in the proper settings (Port, 

baud_rate, etc.). 

4. Refer to Chapter 12, click the menu bar "File" > "Add Existing Project" > "From Zip" to restore the 

demo project (CD-ROM: \Napdos\Win-GRAF\demo-project\dmeo_gps721.zip) in the shipping CD and 

view the program and descriptions.)  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Input Parameters: 

EN:  Data type: BOOL. TRUE: enable it; FALSE: disable it. 

Port:  Data type: DINT. COM port number (can be 1 to 37, depends on PAC). 

(*** Must use a constant value, cannot be a changed value. ***) 

Addr: Data type: DINT. The Net-ID address of the module, can be 1 to 255. 

(*** Must use a constant value, not a changed value ***) 

Sync: Data type: BOOL. Set it as "TRUE" to enable auto time synchronization (note: It will 

work only when the "Time_ok" is also set to "TRUE"). If the time gap between the 

GPS-721 and the PAC is 5 seconds (or more), it will automatically correct the PAC time. 

Set it as "FALSE" to disable this function.  

http://www.icpdas.com/root/product/solutions/industrial_wireless_communication/wireless_solutions/gps-721_tc.html
http://www.icpdas.com/root/product/solutions/industrial_wireless_communication/wireless_solutions/gps-721_tc.html
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GMT_Hr & GMT_Min:  

Data type: DINT. The time difference between local time and GMT (Greenwich 

Mean Time). For example, Beijing and Taipei are +8 hours (GMT_Hr=8, GMT_Min=0), 

United States is -6 hours (GMT_ Hr= -6, GMT_Min=0), and India is +5.5 hours 

(GMT_Hr=5, GMT_Min=30). 

DO0: Data type: BOOL. The Digital output channel of the GPS-721 module. 
  
Output Parameters: 

Tok:   Data type: BOOL. 

TRUE: The communication of GPS-721 

is normal. 
 

FALSE: The communication of GPS-721 

is failed. And all the following 

output values are invalid. 

 

Time_ok: Data type: BOOL. 

TRUE:  Now, the values of Year, Month,  

Day, Hour, Min and Sec are valid. 
 

FALSE: Now, the values of Year, Month,  

Day, Hour, Min and Sec are invalid. 

(i.e., an error or non-real-time value.)  
 

Note:  Each day from 23:59:00 to 00:00:59 (2 minutes), the "Time_ok" will be set as "FALSE" 

automatically and the time synchronization will not be processed. 
 

Year: Data type: DINT. Year ( 2009  ~  ...). 

Month: Data type: DINT. Month ( 1  ~  12). 

Day: Data type: DINT. Day ( 1  ~  31). 

Hour: Data type: DINT. Hour ( 0  ~  23). 

Min: Data type: DINT. Minute ( 0  ~  59). 

Sec: Data type: DINT. Second ( 0  ~  59). 
 

Sat_Num: Data type: DINT. The number of used satellites.  

(0:  no satellites can be found. Or, using 1 ~ 9 satellites) 
 

Location_ok:  Data type: BOOL. 

FALSE: Now, the values of "Long" and "Lati" are invalid (i.e., an error or non-real-time 

value.) 

TRUE: The GPS-721 has got the current  longitude and latitude location.  

(Only when "Location_ok" is set to "TRUE", the values of "Long" and "Lati" are valid. ) 

Long: Data type: REAL. Longitude  (positive value: East ; negative value: West). 

(For example, "25.0121" means 25.0121 degrees.)     

Lati: Data type: REAL. Latitude (positive value: North ; negative value: South). 

(For example, "121.4576" means 121.4576 degrees.)   
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