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第 8 章 連接 DCON I/O 模組 

Win-GRAF PAC 可透過 COM Port (RS-485) 來連接 ICP DAS 的 "I-7000" 與 "I-87KW" 遠端 DCON I/O  

模組，每台 PAC 最多可啟用 16 個 DCON Port，而每個 Port 最多可連接 50 個遠端 DCON 模組 (建議

不要超過 32 個) 。若選用 "I-87KW" 系列 I/O 模組，必須搭配使用 RS-485 I/O 擴充單元 (例如: 

I-87K4/5/8/9 或 RU-87P4/8)。您可在泓格科技的網站上查看詳細的產品資訊: 

www.icpdas.com/root/product/solutions/remote_io/remote_io_products_tc.html 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

在開始使用 "I-7000" 或 "I-87KW" 遠端 DCON I/O 模組前，需先以 "DCON Utility" 軟體設定每一個模組

的 Protocol (請選 DCON 模式)、Address (1 ~ 255)、Baudrate (需與 Win-GRAF PAC 一樣，建議設為 

9600)、Checksum (需與 Win-GRAF PAC 設定一樣，為了通訊安全, 建議設為 "Enabled")、Data format 與

其它 Input/Output 設定 (依需求來設定)。 
 

注意: 

A.  若 I-7000 及 I-87KW 是 AI 模組，則資料格式 (Data format) 必需設定為 "2‘s Complement"。 

例如:  I-7005, I-7013, I-7014D, I-7015, I-7016, I-7017R, I-7018Z, I-7019R, I-7033;  I-87005W, I-87013W, 

            I-87015W, I-87015PW, I-87016W, I-87017W, I-87017RCW, I-87017ZW, I-87017DW, I-87018W,  

            I-87018RW, I-87018ZW, I-87019RW, I-87019ZW, …等類比輸入模組。  

B. 若 I-7000 及 I-87KW 是 AO 模組，則資料格式 (Data format) 必需設定為 “Engineering”。 

 例如: I-7021, I-7022, I-7024, I-7024R;  I-87024W, I-87024UW, I-87024CW, I-87028UW, I-87028CW, 

            I-87028VW, I-87028VW-20V 等類比輸出模組。  
 

 "DCON Utility" 是一個方便好用的軟體工具，可以協助網路搜尋、設定與測試 I/O 模組。 

請至以下網址取得軟體程式與使用手冊 :  

www.icpdas.com/products/dcon/introduction.htm  
 

接下來將說明，Win-GRAF Workbench 中的設定方式。 

http://www.icpdas.com/root/product/solutions/remote_io/remote_io_products_tc.html
http://www.icpdas.com/root/product/solutions/remote_io/rs-485/i-7000_m-7000/i-7000_m-7000_selection_tc.html
http://www.icpdas.com/root/product/solutions/remote_io/rs-485/i-8k_i-87k/i-8k_i-87k_selection.html#b
http://www.icpdas.com/root/product/solutions/remote_io/rs-485/i-7000_m-7000/i-7000_m-7000_selection_tc.html
http://www.icpdas.com/root/product/solutions/remote_io/rs-485/i-8k_i-87k/i-8k_i-87k_selection.html#b
http://www.icpdas.com/products/dcon/introduction.htm
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8.1 設定 "DCON" I/O 卡 

“DCON” 可用來啟用一個 RS-485 Port 來連接遠端的 DCON I/O 模組 (例如: I-7000 系列模組、RU-87P8 

I/O 擴充單元 + I-87KW I/O 模組 或 I-87K8 I/O 擴充單元 + I-87KW I/O 模組)。如需啟用多個 DCON 

Port，請設定多個 “DCON” I/O 卡。(一台 PAC 最多可啟用 16 個 "DCON") 

 

1. 點選 Win-GRAF 工具列的 "Open I/Os" 按鈕來開啟  “I/O Boards” 視窗。 

 
 
 
 

2. 於 Slot8 加入 "DCON" I/O 卡 (參考第四章)，再以滑鼠雙擊該項目來開啟 “Properties” 視窗。 

注意: Slot0 ~ 7 是保留給 PAC I/O 模組，Slot8 (含) 以上供給其它用途使用。 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

參數說明: 

註:  "DCON" 僅支援通訊屬性為 "N,8,1"，表示 "無同位元"、"8 個資料位元" 與 " 1 個停止位元"，

因此請將所有的 DCON I/O 模組設置為 "N,8,1"。 

 

Port:  COM Port 編號 (可設定為 1 ~ 37，視 PAC 而定)。 

Baud_rate:  通訊速率，可設定為 1200, 2400, 4800, 9600, 19200, 38400, 57600, 

115200 (bps)，若設定為其它值，將會採用預設值 "9600"。 

Host_watchdog_Enabled: 1: 表示啟用 Host-watchdog，0: 表示不啟用 

設定為非 0 的值，將會採用 "1"。 

 

設定說明 
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Watchdog_timeout:  單位: ms，可設定為 “3000 ~ 25500”，設定為大於 “25500” 將會採用 

25500 ms (即 25.5 秒); 設定為小於 “3000” 將會採用 3000 ms (即 

 3 秒)。若 "Host_watchdog_Enabled" 設定為 "0" 會忽略此設定。 

Checksum_enabled:  1: 表示啟用，0: 表示不啟用。 

若設定為非 0 的值，將會採用 "1"。(為了通訊安全, 建議啟用 

Checksum)    

Delay_ms_between_polls: 單位: ms，預設值為 0 ms，有效範圍為 "0 ~ 1000"。設定為小於 “0” 將

會採用 0 ms ; 設定為大於 “1000” 將會採用 1000 ms。 

若沒有連接無線模組，請設定為較小的值 (例如: 0 ~ 10)。 

若連接無線模組 (例如: ICP DAS 的 ZT-2570、ZT-2571 Ethernet/RS-485/ 

RS-232 至 ZigBee 轉換器 或 ZB-2000 系列 DIO/AIO 模組)，請設定為 

較大的值 (例如: 30 ~ 100 或 其它值)，而設定較大的值，輪詢 (Polling) 

效率會較慢。 

 

3. 滑鼠雙擊欲設定的項目，並輸入設定值。 

 

 

 

 

 

 

 

 

4. 在 “I/O Boards” 視窗內連上 “DCON” 後，會自動在 “Variables” 視窗中新增 1 個 "BOOL” 輸入 

變數，當 Win-GRAF 有連上 PAC 時，會顯示出 COM Port 的連接狀態。  

(TRUE: 表示 OK  ;  FALSE: 表示錯誤。) 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

http://www.icpdas.com/root/product/solutions/remote_io/remote_io_products_tc.html#ZigBee
http://www.icpdas.com/root/product/solutions/remote_io/remote_io_products_tc.html#ZigBee
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8.2 使用 I/O 功能方塊 

Win-GRAF 支援許多 ICP DAS 的 DCON 遠端 I/O 模組，您可開啟 “程式庫管理員” (參考 1.2.3 節) 或在 

I/O 功能方塊上按 “F1” 鍵來查看這些 I/O 功能方塊的設定說明，本章節將介紹 “D_7065”, “D_7018Z”, 

“D_7083”, “D_87084_freq”, “D_87084_cnt4”, “D_87084_cnt8”, “DL_100T485” ...等 功能方塊。 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

在 LD 程式 - 功能方塊區中，可在 “Blocks” 面板中展開 "ICP DAS – XP-WP-VP" 資料夾，裡面列有許多 

函式 與 功能方塊，您可選擇所需的項目，並將它拖曳到程式編輯區來使用。 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

使用小技巧:   

按 “F1” 鍵，可查看詳細的設定說明。 
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8.2.1 “D_7065” 功能方塊 

“D_7065” 可用來連結一個遠端的 I-7065, I-7065D 繼電器 (Relay) 輸出模組 與 I-7065A, I-7065AD, 

I-7065B, I-7065BD (固態繼電器輸出模組)。 

註:   

1. 所有連接的 DCON I/O 模組需使用 "DCON Utility" 軟體 (見 P8-1) 設定過一次。 

2.  請在 “I/O boards” 視窗加入 “DCON” (見 8.1 節)，並填入正確的參數 (例如:  Port、Baud_rate...)。 

3. 只有在通訊狀態為 "TRUE" 的情況下 (若 "OK" 會回傳 "TRUE")，DI 通道的回傳值才具意義。 

4. 可參考 第 12 章，點選功能表 "File" > "Add Existing Project" > "From Zip"，來回存出貨光碟中的 

範例程式 (CD-ROM: \Napdos\Win-GRAF\demo-project\DEMO_D_7065.zip) 並查看詳細的程式內容。 

 

假設: 使用 PAC 的 COM2 來連接 I-7065 (位址 = 2)，使用 4 個數位輸入通道 與 5 Relay 輸出通道。 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

輸入參數:   

EN: 資料型態: BOOL，設定為 “TRUE": 啟用 ;  設定為 “FALSE“: 不啟用。 

Port: 資料型態: DINT，COM Port 編號 (可設定為 1 ~ 37，視 PAC 而定)。 

(*** 需設定為常數，即不可變動的值 ***) 

Addr: 資料型態: DINT，模組的 Net-ID 位址 (可設定為 1 ~ 255)。 

(*** 需設定為常數，即不可變動的值 ***) 

RL_1 ~ RL_5: 資料型態: BOOL，5 通道 DO 值。 

 

輸出參數:   

OK: 資料型態: BOOL，"TRUE": 表示通訊正常 ;  "FALSE": 表示通訊失敗。 

IN_1 ~ IN_4: 資料型態: BOOL，4 通道 DI 值。 

 
 
 

若通訊正常會

回傳 "TRUE" 

宣告 9 個 BOOL 變數 

(I-7065 的 DI、DO 點) 
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8.2.2 “D_7018Z” 功能方塊 

“D_7018Z” 可用來連結一個遠端的 I-7018Z 模組，此模組是 10 通道熱電耦類比輸入模組，可用來 

量測電壓、電流或溫度，通道可個別設定並具有斷線偵測、過電壓保護功能。 

 

註:   

1. 請先使用 "DCON Utility" 軟體 (見 P8-1) 設定好該模組的適當參數 (例如: Address、Baudrate...)， 

AI 模組的資料格式需設定為 "2‘s Complement"，否則 Win-GRAF PAC 無法正確地讀取該值。 

2. 請在 “I/O boards” 視窗加入 “DCON” (見 8.1 節)，並填入正確的參數 (例如:  Port、Baud_rate...)。 

3. 只有在通訊狀態為 "TRUE" 的情況下 (若 "OK" 會回傳 "TRUE")，AI 通道的回傳值才具意義。 

4. 可參考 第 12 章，點選功能表 "File" > "Add Existing Project" > "From Zip"，來回存出貨光碟中的 

範例程式 (CD-ROM: \Napdos\Win-GRAF\demo-project\DEMO_D_7018z.zip) 並查看詳細的程式內容。 

 

假設: 使用 PAC 的 COM2 來連接 I-7018Z (位址 = 3)，且用來量測攝氏溫度。 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

輸入參數:   

EN: 資料型態: BOOL，設定為 “TRUE": 啟用 ;  設定為 “FALSE“: 不啟用。 

Port: 資料型態: DINT，COM Port 編號 (可設定為 1 ~ 37，視 PAC 而定)。 

(*** 需設定為常數，即不可變動的值 ***) 

Addr: 資料型態: DINT，模組的 Net-ID 位址 (可設定為 1 ~ 255)。 

(*** 需設定為常數，即不可變動的值 ***) 

 

若通訊正常會

回傳 "TRUE" 

宣告 10 個 REAL 變數 

(I-7018Z 的 AI 點) 
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Tmp_F:  資料型態: DINT，溫度格式可設定為 1 或 2。 

1 : 表示為攝氏溫度  

2 : 表示為華氏溫度 

若設定為其它值，則會取用 "1: 攝氏溫度"。 

輸出參數:   

OK: 資料型態: BOOL，"TRUE": 表示通訊正常 ;  "FALSE": 表示通訊失敗。 

V_0 ~ V_9: 資料型態: REAL，10 通道 AI 值。 

若在 "DCON Utility" 選用了通道為電壓類型，表示該回傳值的單位為 "V"。 

例如，回傳值為 0.85421 表示 0.85421 V 或 854.21 mV。 

若在 "DCON Utility" 選用了通道為電流類型，表示該回傳值的單位為 "mA"。 

例如，回傳值為 1.5567 表示 1.5567 mA。 

若在 "DCON Utility" 選用了通道為溫度類型，表示該回傳值的單位為 "度"。 

例如，回傳值為 25.75 表示 25.75 度。 

 

斷線偵測: 

若溫度值大於 "9000.0" 表示， 

1. 溫度感測器可能斷線。 

2. 溫度感測器可能損毀。 

3. DCON  模組的設定 與 溫度感測器不符。 

4. 感測器量到錯誤的電阻值。 
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8.2.3 “D_7083” 功能方塊 

“D_7083” 可用來連結一個遠端的 I-7083, I-7083D, I-7083B, I-7083BD 模組，此模組是 3 軸 32 位元 

編碼器輸入模組。 

 

註:  

1. 為了取得 I-7083, I-7083D, I-7083B, I-7083BD 模組的 Encoder 值，需先使用 "D_7083" 功能方塊之

後，再搭配  "Counter_Start", "Counter_Stop", "Counter_Get", "Counter_State" 與 "Counter_Reset"  

函式 (可參考 4.9 節) 來操作這些模組的 Encoder 通道。 

2. 請先使用 "DCON Utility" 軟體 (見 P8-1) 設定好該模組的適當參數 (例如: Address、Baudrate...)， 

AI 模組的資料格式需設定為 "2‘s Complement"，否則 Win-GRAF PAC 無法正確地讀取該值。 

3. 請在 “I/O boards” 視窗加入 “DCON” (見 8.1 節)，並填入正確的參數 (例如:  Port、Baud_rate...)。 

4. 只有在通訊狀態為 "TRUE" 的情況下 (若 "OK" 會回傳 "TRUE")，AI 通道的回傳值才具意義。 

5. 可參考 第 12 章，點選功能表 "File" > "Add Existing Project" > "From Zip"，來回存出貨光碟中的 

範例程式 (CD-ROM: \Napdos\Win-GRAF\demo-project\DEMO_D_7083.zip) 並查看詳細的程式內容。 

 

假設: 使用 PAC 的 COM2 來連接 I-7065 (位址 = 4)，使用 3 個數位輸入通道。 

 
 
 
 
 
 
 
 
 
 
 
 

輸入參數:   

EN: 資料型態: BOOL，設定為 “TRUE": 啟用 ;  設定為 “FALSE“: 不啟用。 

Port: 資料型態: DINT，COM Port 編號 (可設定為 1 ~ 37，視 PAC 而定)。 

(*** 需設定為常數，即不可變動的值 ***) 

Addr: 資料型態: DINT，模組的 Net-ID 位址 (可設定為 1 ~ 255)。 

(*** 需設定為常數，即不可變動的值 ***) 

 

輸出參數:   

OK: 資料型態: BOOL，"TRUE": 表示通訊正常 ;  "FALSE": 表示通訊失敗。 

Z_0 ~ Z_2: 資料型態: BOOL，3 軸 Z-index DI 值。 

 
 
 

若通訊正常會

回傳 "TRUE" 

宣告 3 個 BOOL 變數 

(I-7083 的 Z-index DI 點) 

若要讀取/操作 Encoder，

請參考  4.9 節。 
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8.2.4 “D_87084_FREQ” 功能方塊 

"D_87084_freq" 可用來連結一個在 I/O 擴充單元 (例如: I-87K4/5/8/9、RU-87P4 或 RU-87P8) 上的

I-87084W 模組，並用來量測 8 通道的頻率值。 

 

註:  

1. 請先使用 "DCON Utility" 軟體 (見 P8-1) 設定好該模組的適當參數 (例如: Address、Baudrate...)，

頻率的資料格式需設定為 " Hex format"，否則該功能將無效。 

2. 請在 “I/O boards” 視窗加入 “DCON” (見 8.1 節)，並填入正確的參數 (例如:  Port、Baud_rate...)。 

3. 只有在通訊狀態為 "TRUE" 的情況下 (若 "OK" 會回傳 "TRUE")，AI 通道的回傳值才具意義。 

4. 可參考 第 12 章，點選功能表 "File" > "Add Existing Project" > "From Zip"，回存出貨光碟中的範例

程式 (CD-ROM:\Napdos\Win-GRAF\demo-project\DEMO_D_87084_FR.zip) 並查看詳細的程式內容。 

 

假設: 使用 PAC 的 COM2 來連接 I-87084W (位址 = 5)，使用 8 個頻率輸入通道。 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

輸入參數:   

EN: 資料型態: BOOL，設定為 “TRUE": 啟用 ;  設定為 “FALSE“: 不啟用。 

Port: 資料型態: DINT，COM Port 編號 (可設定為 1 ~ 37，視 PAC 而定)。 

(*** 需設定為常數，即不可變動的值 ***) 

Addr: 資料型態: DINT，模組的 Net-ID 位址 (可設定為 1 ~ 255)。 

(*** 需設定為常數，即不可變動的值 ***) 

 

輸出參數:   

OK: 資料型態: BOOL，"TRUE": 表示通訊正常 ;  "FALSE": 表示通訊失敗。 

Freq_0 ~ Freq_7: 資料型態: DINT，8 通道頻率值 (單位: Hz)。 

 
 

若通訊正常會

回傳 "TRUE" 

宣告 8 個 DINT 變數 

(I-87084W 的 頻率輸入 點) 
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8.2.5 “D_87084_CNT4” 功能方塊 

"D_87084_CNT4" 可用來連結一個在 I/O 擴充單元 (例如: I-87K4/5/8/9、RU-87P4 或 RU-87P8) 上的

I-87084W 模組，並用來量測 4 通道的計數值。 

 

註:  

1. 請先使用 "DCON Utility" 軟體 (見 P8-1) 設定好該模組的適當參數 (例如: Address、Baudrate...)，

頻率的資料格式需設定為 " Hex format"，否則該功能將無效。 

2. 請在 “I/O boards” 視窗加入 “DCON” (見 8.1 節)，並填入正確的參數 (例如:  Port、Baud_rate...)。 

3. 為了由遠端 I-87084W 模組取得 4 通道的 Counter 值，需先使用 "D_87084_CNT4" 功能方塊，並

搭配  "Counter_Start", "Counter_Stop", "Counter_Get", "Counter_State" 與 "Counter_Reset" 函式  

(可參考 4.9 節) 來操作該模組的 Counter 通道。 

4. 只有在通訊狀態為 "TRUE" 的情況下 (若 "OK" 會回傳 "TRUE")，AI 通道的回傳值才具意義。 

5. 可參考 第 12 章，點選功能表 "File" > "Add Existing Project" > "From Zip"，回存出貨光碟中的範例

程式 (CD-ROM:\Napdos\Win-GRAF\demo-project\DEMO_D_87084_C4.zip) 並查看詳細的程式內容。 

 

假設: 使用 PAC 的 COM2 來連接 I-87084W (位址 = 6)，使用 4 個計數通道。 

 
 
 
 
 
 
 
 
 
 
 
 
 

輸入參數:   

EN: 資料型態: BOOL，設定為 “TRUE": 啟用 ;  設定為 “FALSE“: 不啟用。 

Port: 資料型態: DINT，COM Port 編號 (可設定為 1 ~ 37，視 PAC 而定)。 

(*** 需設定為常數，即不可變動的值 ***) 

Addr: 資料型態: DINT，模組的 Net-ID 位址 (可設定為 1 ~ 255)。 

(*** 需設定為常數，即不可變動的值 ***) 

 

輸出參數:   

OK: 資料型態: BOOL，"TRUE": 表示通訊正常 ;  "FALSE": 表示通訊失敗。 

 
 
 
 

若通訊正常會

回傳 "TRUE" 
若要讀取/操作 Counter，

請參考  4.9 節。 
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8.2.6 “D_87084_CNT8” 功能方塊 

"D_87084_CNT8" 可用來連結一個在 I/O 擴充單元 (例如: I-87K4/5/8/9、RU-87P4 或 RU-87P8) 上的

I-87084W 模組，並用來量測 8 通道的計數值。 

 

註:  

1. 請先使用 "DCON Utility" 軟體 (見 P8-1) 設定好該模組的適當參數 (例如: Address、Baudrate...)，

頻率的資料格式需設定為 " Hex format"，否則該功能將無效。 

2. 請在 “I/O boards” 視窗加入 “DCON” (見 8.1 節)，並填入正確的參數 (例如:  Port、Baud_rate...)。 

3. 為了由遠端 I-87084W 模組取得 8 通道的 Counter 值，需先使用 "D_87084_CNT8" 功能方塊，並

搭配  "Counter_Start", "Counter_Stop", "Counter_Get", "Counter_State" 與 "Counter_Reset" 函式  

(可參考 4.9 節) 來操作該模組的 Counter 通道。 

4. 只有在通訊狀態為 "TRUE" 的情況下 (若 "OK" 會回傳 "TRUE")，AI 通道的回傳值才具意義。 

5. 可參考 第 12 章，點選功能表 "File" > "Add Existing Project" > "From Zip"，回存出貨光碟中的範例

程式 (CD-ROM:\Napdos\Win-GRAF\demo-project\DEMO_D_87084_C8.zip) 並查看詳細的程式內容。 

 

假設: 使用 PAC 的 COM2 來連接 I-87084W (位址 = 7)，使用 8 個計數通道。 

 
 
 
 
 
 
 
 
 
 
 
 
 

輸入參數:   

EN: 資料型態: BOOL，設定為 “TRUE": 啟用 ;  設定為 “FALSE“: 不啟用。 

Port: 資料型態: DINT，COM Port 編號 (可設定為 1 ~ 37，視 PAC 而定)。 

(*** 需設定為常數，即不可變動的值 ***) 

Addr: 資料型態: DINT，模組的 Net-ID 位址 (可設定為 1 ~ 255)。 

(*** 需設定為常數，即不可變動的值 ***) 

 

輸出參數:   

OK: 資料型態: BOOL，"TRUE": 表示通訊正常 ;  "FALSE": 表示通訊失敗。 

 
 
 
 

若通訊正常會

回傳 "TRUE" 
若要讀取/操作 Counter，

請參考  4.9 節。 
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8.2.7 “DL_100T485” 功能方塊 

"DL_100T485" 可用來連結一個遠端的 DL_100T485 模組，來讀取溫度與濕度值。 

產品網頁: www.icpdas.com/root/product/solutions/remote_io/rs-485/dl_series/dl-100t485.html 

註:  

1. 請先使用隨貨光碟中的 "DL-100T485 Utility" 軟體，設定好該模組的適當參數 (例如: Module ID)，

DL-100T485 預設 Address (ID) 為 "1"，Baudrate 為 "9600"，Checksum 為 "Disable"。 

2. 請在 “I/O boards” 視窗加入 “DCON” (見 8.1 節)，並填入正確的參數 (例如:  Port、Baud_rate...)。 

3. 只有在通訊狀態為 "TRUE" 的情況下 (若 "OK" 會回傳 "TRUE")，AI 通道的回傳值才具意義。 

4. 可參考 第 12 章，點選功能表 "File" > "Add Existing Project" > "From Zip"，回存出貨光碟中的範例

程式 (CD-ROM:\Napdos\Win-GRAF\demo-project\DEMO_DL_100T485.zip) 並查看詳細的程式內容。 

 

假設: 使用 PAC 的 COM2 來連接 DL_100T485 (位址 = 1)，用來量測濕度值。 

 
 
 
 
 
 
 
 
 
 
 
 

輸入參數:   

EN: 資料型態: BOOL，設定為 “TRUE": 啟用 ;  設定為 “FALSE“: 不啟用。 

Port: 資料型態: DINT，COM Port 編號 (可設定為 1 ~ 37，視 PAC 而定)。 

(*** 需設定為常數，即不可變動的值 ***) 

Addr: 資料型態: DINT，模組的 Net-ID 位址 (預設為 "1"，可設定為 1 ~ 255)。 

(*** 需設定為常數，即不可變動的值 ***) 

 

輸出參數:   

OK: 資料型態: BOOL，"TRUE": 表示通訊正常 ;  "FALSE": 表示通訊失敗。 

RH: 資料型態: REAL，回傳值為相對溼度 (單位: %)。 

例如: 回傳值為 "45.7" 表示 45.7%。 

Temp_C: 資料型態: REAL，回傳值為攝氏溫度 

例如: 回傳值為 "25.7" 表示 25.7 ℃。 

Temp_F: 資料型態: REAL，回傳值為華氏溫度 

例如: 回傳值為 "78.26" 表示 78.26 ℉。 

 
 

若通訊正常會

回傳 "TRUE" 

宣告 2 個 REAL 變數 

(DL-100T485 的溼度與溫度值) 

http://www.icpdas.com/root/product/solutions/remote_io/rs-485/dl_series/dl-100t485.html
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8.2.8 “D_GPS721” 功能方塊 

“D_GPS721” 可用來連結一個 “GPS-721” 遠端 GPS 接收模組 (內含 1 DO, 1 PPS 輸出通道)，用來接收

GPS 衛星訊號，即時取得精確的時間，日期，經/緯度，作為定位與校時使用。另外，“GPS-721”  

具有 RS-232 介面，遠端主機可透過 RS-485 的 DCON 命令來詢問 GPS-721 的 GPS 資訊，也可遠端 

控制其內建的 DO 通道，而 PPS (Pulse Per Second) 功能，更可用來做為簡單的時間同步。 

產品網頁: 

http://www.icpdas.com/root/product/solutions/industrial_wireless_communication/wireless_solutions
/gps-721_tc.html 

註:  

1. 一台 PAC 只能使用一個 GPS-721 模組。 

2. 所有連接的模組皆需設定過一次，請先使用 "DCON Utility" 軟體 (見 P8-1) 設定 GPS-721 模組的 

相關參數，其預設 Address (ID) 為 "1"，Baudrate 為 "9600"，Checksum 為 "Disable"。 

3. 請在 “I/O boards” 視窗加入 “DCON” (見 8.1 節)，並填入正確的參數 (例如:  Port、Baud_rate...)。 

4. 可參考 第 12 章，點選功能表 "File" > "Add Existing Project" > "From Zip"，回存出貨光碟中的範例

程式 (CD-ROM:\Napdos\Win-GRAF\demo-project\dmeo_gps721.zip) 並查看詳細的程式內容。 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

輸入參數:   

EN: 資料型態: BOOL，設定為 "TRUE": 啟用 ;  設定為 "FALSE": 不啟用。 

Port: 資料型態: DINT，COM Port 編號 (可設定為 1 ~ 37，視 PAC 而定)。 

(*** 需設定為常數，即不可變動的值 ***) 

Addr: 資料型態: DINT，模組的 Net-ID 位址 (預設為 "1"，可設定為 1 ~ 255)。 

(*** 需設定為常數，即不可變動的值 ***) 

Sync: 資料型態: BOOL，設定為 "TRUE" 來啟用時間自動同步功能，當 GPS-721 與 PAC 

時間差距 5 秒 (或更多) 會自動校正 PAC 時間。設定為 "FALSE" 來關閉此功能。 

("Time_ok" 為 "TRUE" 時，此功能才有效。) 

http://www.icpdas.com/root/product/solutions/industrial_wireless_communication/wireless_solutions/gps-721_tc.html
http://www.icpdas.com/root/product/solutions/industrial_wireless_communication/wireless_solutions/gps-721_tc.html
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GMT_Hr & GMT_Min:  

資料型態: DINT，目前所在位置與格林威治標準時間的時差。例如: 北京 與 台北是

加 8 小時 (GMT_Hr=8，GMT_Min=0)，美國是減 6 小時(GMT_ Hr= -6，GMT_Min=0)，

印度是加 5.5 小時 (GMT_Hr=5，GMT_Min=30)。 

DO0: 資料型態: BOOL，GPS-721 模組的數位輸出通道 (DO0)。 

  

輸出參數:    

Tok:   資料型態: BOOL， 

TRUE: GPS-721 通訊正常。  

FALSE: GPS-721 通訊失敗，以下的 

回傳值皆無意義。 
 

Time_ok: 資料型態: BOOL， 

TRUE:  此時 Year, Month, Day, Hour,  

Min, Sec 的值是有意義的。 
 

FALSE: 此時 Year, Month, Day, Hour,  

Min, Sec 的值無意義 (即， 

錯誤的 或 非即時的數據)。 
 

註: 每天的 23:59:00 – 00:00:59 (2 分鐘)，“Time_ok" 會自動設為 "FALSE" 並且不會進行時間校正。 
 

Year: 資料型態: DINT，年 ( 2009  ~  ...)。 

Month: 資料型態: DINT，月 ( 1  ~  12)。 

Day: 資料型態: DINT，日 ( 1  ~  31)。 

Hour: 資料型態: DINT，時 ( 0  ~  23)。 

Min: 資料型態: DINT，分 ( 0  ~  59)。 

Sec: 資料型態: DINT，秒 ( 0  ~  59)。 
 

Sat_Num: 資料型態: DINT，使用衛星數量 (0: 未發現衛星 或 使用 1 ~ 9 顆衛星) 。 
 

Location_ok:  資料型態: BOOL， 

FALSE: 此時 Long, Lati 的值無意義 (即，錯誤的 或 非即時的數據)。 

TRUE: 已取得目前位置的經/緯度。 

(只有在 "Location_ok" 為 "TRUE" 時，Long 與 Lati 值才正確。 ) 

Long: 資料型態: REAL，經度  (正數: 表示東方，負數: 表示西方)。 

(例如: "25.0121" 表示 25.0121 度。)     

Lati: 資料型態: REAL，緯度  (正數: 表示北方，負數: 表示南方)。 

(例如: "121.4576" 表示 121.4576 度。)   
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